SpyGlass ReleaseNotes

download SpyGlass ReleaseNotes

of 118

  • date post

    28-Apr-2015
  • Category

    Documents

  • view

    2.785
  • download

    130

Embed Size (px)

Transcript of SpyGlass ReleaseNotes

SpyGlass 4.7.1 Release Notes

This Release Notes document highlights new features and enhancements made in the SpyGlass 4.7.1 release. This release supersedes all the prior SpyGlass releases. This document contains the following topics:

Platform Support Licenses Re-compilation Requirements Future Support Notices Documentation of Patch Releases Overview of SpyGlass 4.7.1 Release SpyGlass Core SpyGlass RTL Modification Engine (RME) Atrenta Console Atrenta Products Documentation List of Incidents Fixed in the SpyGlass 4.7.1 Release Overview of SpyGlass 4.7.0 Release SpyGlass Core SpyGlass RTL Modification Engine (RME) Atrenta Console Atrenta Products Documentation List of Incidents Fixed in the SpyGlass 4.7.0 Release Atrenta Legacy Support PolicyOur policy is to support the current and two prior major releases of the software. For example, with the 4.7.0 release, support for releases prior to 4.5.0 of the SpyGlass platform ceases. For details on our legacy support policy, please refer to the Support page of our website.

SpyGlass Release Notes

1

SpyGlass Release Notes

If one of your installations is still using an un-supported release, please contact Atrenta support or your local salesperson. We will work with you to develop a plan to continue support of that release until you are able to move to a supported release. Our intention in supporting this policy is to improve the quality of our service by allowing our team to focus on current release optimization. While moving to this process, we do not want to create undue hardship for you. Contact us soon so that we may develop a support plan that meets your needs. Thank you for your cooperation and understanding.

Best Regards, The Atrenta Team

2

July 2012

4.7.1

SpyGlass Release NotesPlatform Support

Platform SupportRule-CheckingSpyGlass 4.7.1 was developed and tested on the following platforms:Hardware Platform Intel x86 (32 bit) Compiled and tested on... RHEL 4.0 Also tested on... RHEL 4.8, RHEL 5.2, RHEL 5.6, RHEL 6.0, SUSE 10 SP2, SUSE 11 SP1, CENTOS 5.4 RHEL 4.8, RHEL 5.2, RHEL 5.6, RHEL 6.0, SUSE 10 SP2, SUSE 11 SP1, CENTOS 5.4 RHEL 4.8, RHEL 5.2, RHEL 5.6, RHEL 6.0, SUSE 10 SP2, SUSE 11 SP1, CENTOS 5.4

AMD Opteron (32/64-bit)

RHEL 4.0

Intel Xeon/EMT64 (64-bit)

-

NOTE: On the Linux 64-bit platform, 64-bit SpyGlass binaries are executed by default. To enforce 32-bit binary execution, use the -32bit command-line option except on the RHEL 6.0 platform. The -32bit command-line option does not work on the default 64-bit installation of the RHEL 6.0 platform because the required 32-bit libraries are not installed on the 64-bit installation. NOTE: For best results while using the Graphical User Interface (GUI), it is recommended to use 16-bit color depth and a minimum resolution of 1024x768.

4.7.1

July 2012

3

SpyGlass Release NotesPlatform Support

Custom Product BuildingFor SpyGlass 4.7.1 custom product development, compile custom products on the following platforms:Hardware Platform Intel IA (32 bit) To use on Compile on Additional spygenlib Command-line Option required

RHEL 4.0, RHEL 5.0, SLES 9.0, SLES 10.0 RHEL 4.0, RHEL 5.0, SLES 9.0, SLES 10.0 RHEL 4.0, RHEL 5.0, SLES 9.0, SLES 10.0

RHEL 4.0

AMD Opteron (64 bit) Intel Xeon/EMT64 (64-bit)

RHEL 4.0

-64bit

-

-64bit

NOTE: SpyGlass 3.8.x and later versions are not available on the HPUX platform. NOTE: For Linux 32-bit and Linux 64-bit platforms, the compiler version is gcc 4.2.4. NOTE: For Solaris 32-bit and Solaris 64-bit platforms, the compiler version is Sun Studio 11.

Supported PlatformsThe details of the supported platforms are described below:

The following table defines the supported platforms for Atrenta licenseservers in 2007-June 2010 (SpyGlass 3.8.x, 3.9.x, 4.0.x, 4.1.x, 4.2.x, 4.3.x) - Flexlm version 9.5:Hardware Platform Baseline support (compiled & tested on) Solaris 8 RHEL 4.0 Also supported (tested on) Solaris 9, Solaris 10 RHEL 5.0 SLES 9.0, 10.0

Sun Sparc (32 bit and 64 bit) Intel x86 (32 bit)

4

July 2012

4.7.1

SpyGlass Release NotesPlatform Support

Hardware Platform

Baseline support (compiled & tested on) RHEL 4.0 -

Also supported (tested on) RHEL 5.0 SLES 9.0, 10.0 RHEL 4.0, 5.0 SLES 9.0, 10.0

AMD Opteron (32/64 bit) Intel Xeon/EMT64 (64-bit)

The following table defines the supported platforms for Atrenta licenseservers starting July 2010 (SpyGlass 4.4.0 onwards) - Flexlm version 11.7:Hardware Platform Baseline support (compiled & tested on) Solaris 10.0 RHEL 4.0 (Update 2) Also supported (tested on) Solaris 9, Solaris 10 RHEL 5.0, 5.1, 5.2, 5.3, 5.4 SLES 10.0, 10.0-SP3 RHEL 5.0, 5.1, 5.2, 5.3, 5.4 SLES 10.0, 10.0-SP3 RHEL 4.0 (Update 2), 5.0, 5.1, 5.2, 5.3, 5.4 SLES 10.0, 10.0-SP3

Sun Sparc (32 bit and 64 bit) Intel x86 (32 bit)

AMD Opteron (32/64 bit)

RHEL 4.0 (Update 2)

Intel Xeon/EMT64 (64-bit)

-

The following table defines the supported platforms for Atrenta licenseservers starting July 2012 (SpyGlass 4.7.1 onwards) - Flexlm version 11.10:

4.7.1

July 2012

5

SpyGlass Release NotesPlatform Support

Hardware Platform

Baseline support (compiled & tested on) Solaris 10.0 RHEL 4.0

Also supported (tested on) Solaris 9, Solaris 10 RHEL 4.8, RHEL 5.2, RHEL 5.6, RHEL 6.0, SUSE 10 SP2, SUSE 11 SP1, CENTOS 5.4 RHEL 4.8, RHEL 5.2, RHEL 5.6, RHEL 6.0, SUSE 10 SP2, SUSE 11 SP1, CENTOS 5.4 RHEL 4.8, RHEL 5.2, RHEL 5.6, RHEL 6.0, SUSE 10 SP2, SUSE 11 SP1, CENTOS 5.4

Sun Sparc (32 bit and 64 bit) Intel x86 (32 bit)

AMD Opteron (32/64-bit)

RHEL 4.0

Intel Xeon/EMT64 (64-bit)

-

6

July 2012

4.7.1

SpyGlass Release NotesLicenses

LicensesStarting with the SpyGlass 4.7.1 release, Atrenta has upgraded to FlexNet Publisher version 11.10 from Flexera Inc. To successfully check out licenses in the SpyGlass 4.7.1 release (or later), users must restart the license server by using a higher version of lmgrd (version 11.10 or higher) and Atrenta vendor daemon file (version 11.10). This is a one time activity. All the license server utility files and Atrenta vendor daemon files for the 11.10 version are present under the SpyGlass installation directory, SpyGlass-4.7.1/SPYGLASS_HOME/flexlm_v1110/. Users must set the license environment variable ATRENTA_LICENSE_FILE or LM_LICENSE_FILE in the port@server format rather than the file name format.

4.7.1

July 2012

7

SpyGlass Release NotesRe-compilation Requirements

Re-compilation RequirementsWhen a new SpyGlass version is released with new features and enhancements, some user components need to be re-compiled to take advantage of the new features. This section describes different user components and need to re-compile, if any.

VHDL LibrariesPre-compiling VHDL libraries is a standard feature. Normally, you do not need to re-compile the VHDL libraries when the object model format or the dump location has not changed. When the object model format is changed, SpyGlass prompts you to re-compile based on the internally maintained magic number.

Need to RecompileVHDL libraries compiled with previous versions of SpyGlass are not compatible with this version of SpyGlass. Therefore, the user should recompile their libraries.

Verilog LibrariesSpyGlass provides the facility to precompile Verilog libraries and use them just like precompiled VHDL libraries (standard feature). Normally, you do not need to re-compile the Verilog libraries when the object model format or the dump location has not changed. When the object model format is changed, SpyGlass prompts the user to re-compile based on the internally maintained magic number.

Need to RecompileVerilog libraries compiled with previous versions of SpyGlass are not compatible with this version of SpyGlass. Therefore, the user should

8

July 2012

4.7.1

SpyGlass Release NotesRe-compilation Requirements

recompile their libraries.

SpyGlass-format Gate LibrariesSpyGlass format gate libraries (.sglib files) are created by pre-compiling Synopsys Libraries (.lib files) by using SpyGlass Library Compiler (SpyGlass library compiler). The SpyGlass Library Compiler is enhanced with every release to support more gate cell types and/or enhanced to improve working of already supported gate cell types.

Need to RecompileWorking with Libraries Compiled Prior to 4.2.0 ReleaseSuch libraries are compatible across releases. However, it is always recommended to recompile them using the latest SpyGlass library compiler for the following reasons.

Netlist models of library cells that are stored in the sglib are optimized inevery release. Therefore, using an optimized netlist of library cells will show improvements in SpyGlass runtime.

The loading process of sglibs was greatly improved in the SpyGlass

4.2.0 release. However, an sglib that is compiled prior to the 4.2.0 release takes much longer to load as compared with an sglib compiled with the 4.2.0 or post 4.2.0 release.

Gate libraries compiled prior to 4.2.0 used to store the original .lib itself in an encrypted format, which was parsed again during usage. Therefore, it was compatible across releases. However, re-parsing resulted in significant .sglib load time, which has been improved starting from the 4.2.0 release.

Working with Libraries Compiled with the 4.2.0 and Post 4.2.0 ReleaseThe SpyGlass library compiler flow was completely overhauled in the 4.2.0 release, and instead of storing .lib files in an e