IOS XR Workbook

download IOS XR Workbook

of 232

Transcript of IOS XR Workbook

  • 8/10/2019 IOS XR Workbook

    1/232

    Cisco IOS XRWorkbookCisco IOS XR Practice Labs

    This workbook aims to give network engineers the chance to practice new Cisco

    software : IOS XR combined with Cisco IOS software , the workbook mainly focus

    on MPLS technologies and different MPLS VPN implementantions using GNS3 to

    simulate , its a good preparation guide for both CCNP SP and CCIE SP tracks

    2014

    Mohammad Khalil CCIE #35484 (RS,SP)

    www.nmsboost.com

    9/4/2014

  • 8/10/2019 IOS XR Workbook

    2/232

    1

    ContentsMPLS L3VPN Static PE-CE ...................................................................... 2

    MPLS L3VPN RIPv2 PE-CE .................................................................... 12

    MPLS L3VPN OSPF PE-CE ..................................................................... 21

    MPLS L3VPN OSPF Sham-link ............................................................... 31

    MPLS L3VPN EIGRP PE-CE ................................................................... 41

    MPLS L3VPN BGP PE-CE ...................................................................... 51

    MPLS Tunneling .................................................................................. 61

    Carrier Supporting Carrier (CsC) 1 ........................................................ 71

    Carrier supporting Carrier (CsC) 2 ........................................................ 89

    MPLS 6VPE Static ............................................................................. 111

    MPLS 6VPE OSPF .............................................................................. 128

    MPLS 6VPE EIGRP ............................................................................. 145

    MPLS 6VPE BGP ................................................................................ 163

    Inter-AS Option-A ............................................................................. 180

    Inter-AS Option-B ............................................................................. 195

    Export Maps ..................................................................................... 208

    SNMP .............................................................................................. 220

    VPLS ............................................................................................... 224

  • 8/10/2019 IOS XR Workbook

    3/232

    2

    MPLS L3VPN Static PE-CE

    Network Diagram

    XR1

    R2

    R3

    192.168.102.0/24

    192.168.101.0/24 192.168.23.0/24

    192.168.34.0/24

    OSPF A0

    AS1

    Lo0 1.1.1.1/32

    Lo0 3.3.3.3/32

    Lo0 4.4.4.4/32

    10.10.10.10/32

    Lo0 2.2.2.2/32

    Static

    R1

    Static

    R4

    Initial Configurations

    R1interface Loopback0ip address 1.1.1.1 255.255.255.255

    interface FastEthernet0/0ip address 192.168.102.1 255.255.255.0duplex autospeed auto

    no shutdown

    R2interface Loopback0

    ip address 2.2.2.2 255.255.255.255

    interface FastEthernet0/0

    ip address 192.168.101.2 255.255.255.0duplex auto

  • 8/10/2019 IOS XR Workbook

    4/232

    3

    speed autompls ip

    no shutdown

    interface FastEthernet0/1

    ip address 192.168.23.2 255.255.255.0speed 100full-duplex

    mpls ipno shutdown

    R3interface Loopback0ip address 3.3.3.3 255.255.255.255

    interface FastEthernet0/0ip address 192.168.23.3 255.255.255.0

    speed 100full-duplexmpls ip

    no shutdown

    interface FastEthernet0/1ip address 192.168.34.3 255.255.255.0speed 100full-duplex

    no shutdown

    R4interface Loopback0ip address 4.4.4.4 255.255.255.255

    interface FastEthernet0/0ip address 192.168.34.4 255.255.255.0

    speed 100full-duplexno shutdown

    XR1interface Loopback0

    ipv4 address 10.10.10.10 255.255.255.0

    interface GigabitEthernet0/0/0/0

    cdpipv4 address 192.168.102.10 255.255.255.0duplex fullno shutdown

  • 8/10/2019 IOS XR Workbook

    5/232

    4

    interface GigabitEthernet0/0/0/2

    cdpipv4 address 192.168.101.10 255.255.255.0no shutdown

  • 8/10/2019 IOS XR Workbook

    6/232

    5

    Configurations

    R1ip route 0.0.0.0 0.0.0.0 192.168.102.10

    R2router ospf 1

    router-id 2.2.2.2network 2.2.2.2 0.0.0.0 area 0network 192.168.23.2 0.0.0.0 area 0

    network 192.168.101.2 0.0.0.0 area 0

    mpls label protocol ldp

    mpls ldp router-id Loopback0 force

    interface FastEthernet0/0

    mpls ip

    interface FastEthernet0/1mpls ip

    R4ip route 0.0.0.0 0.0.0.0 192.168.34.3

    R3

    ip vrf MSSK

    rd 100:1route-target export 100:1

    route-target import 100:1

    mpls label protocol ldp

    mpls ldp router-id Loopback0 force

    interface FastEthernet0/0

    mpls ip

    router ospf 1

    router-id 3.3.3.3

    network 3.3.3.3 0.0.0.0 area 0network 192.168.23.3 0.0.0.0 area 0

    ip route vrf MSSK 4.4.4.4 255.255.255.255 192.168.34.4

    router bgp 1no bgp default ipv4-unicast

    bgp log-neighbor-changesneighbor 10.10.10.10 remote-as 1

  • 8/10/2019 IOS XR Workbook

    7/232

    6

    neighbor 10.10.10.10 update-source Loopback0

    address-family vpnv4neighbor 10.10.10.10 activateneighbor 10.10.10.10 send-community both

    exit-address-family

    address-family ipv4 vrf MSSK

    network 192.168.34.0 mask 255.255.255.0redistribute staticno synchronizationexit-address-family

    XR1

    vrf MSSKaddress-family ipv4 unicastimport route-target

    100:1

    export route-target

    100:1

    interface GigabitEthernet0/0/0/0vrf MSSKipv4 address 192.168.102.10 255.255.255.0

    router ospf 1router-id 10.10.10.10area 0interface Loopback0

    interface GigabitEthernet0/0/0/2

    router static

    vrf MSSKaddress-family ipv4 unicast1.1.1.1/32 192.168.102.1

    router bgp 1address-family vpnv4 unicast

    neighbor 3.3.3.3remote-as 1

    update-source Loopback0address-family vpnv4 unicast

    vrf MSSK

  • 8/10/2019 IOS XR Workbook

    8/232

    7

    rd 100:1address-family ipv4 unicast

    network 192.168.102.0/24redistribute static

    mpls ldprouter-id 10.10.10.10interface GigabitEthernet0/0/0/2

    Verifications

    R1#sh ip routeCodes: C - connected, S - static, R - RIP, M - mobile, B - BGP

    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2

    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route

    Gateway of last resort is 192.168.102.10 to network 0.0.0.0

    1.0.0.0/32 is subnetted, 1 subnetsC 1.1.1.1 is directly connected, Loopback0C 192.168.102.0/24 is directly connected, FastEthernet0/0

    S* 0.0.0.0/0 [1/0] via 192.168.102.10

    R1#ping 4.4.4.4

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

    !!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 532/658/764 ms

    R1#ping 4.4.4.4 source lo0

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

    Packet sent with a source address of 1.1.1.1!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 548/569/600 ms

    R1#traceroute 4.4.4.4 source lo0 numeric

    Type escape sequence to abort.

    Tracing the route to 4.4.4.4

  • 8/10/2019 IOS XR Workbook

    9/232

    8

    1 192.168.102.10 4 msec 184 msec 188 msec2 192.168.101.2 [MPLS: Labels 16/21 Exp 0] 600 msec 560 msec 564 msec

    3 192.168.34.3 [MPLS: Label 21 Exp 0] 564 msec 472 msec 472 msec4 192.168.34.4 660 msec 656 msec 664 msec

    R4#sh ip routeCodes: C - connected, S - static, R - RIP, M - mobile, B - BGP

    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route

    Gateway of last resort is 192.168.34.3 to network 0.0.0.0

    4.0.0.0/32 is subnetted, 1 subnets

    C 4.4.4.4 is directly connected, Loopback0C 192.168.34.0/24 is directly connected, FastEthernet0/0S* 0.0.0.0/0 [1/0] via 192.168.34.3

    R4#ping 1.1.1.1

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:!!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 628/672/752 ms

    R4#ping 1.1.1.1 source lo0

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:Packet sent with a source address of 4.4.4.4!!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 320/656/856 ms

    R4#traceroute 1.1.1.1 source lo0 numeric

    Type escape sequence to abort.Tracing the route to 1.1.1.1

    1 192.168.34.3 132 msec 184 msec 188 msec2 192.168.23.2 [MPLS: Labels 17/16003 Exp 0] 872 msec 660 msec 660 msec

    3 192.168.101.10 [MPLS: Label 16003 Exp 0] 688 msec 660 msec 564 msec4 192.168.102.1 692 msec 656 msec 564 msec

  • 8/10/2019 IOS XR Workbook

    10/232

    9

    R3#sh ip route vrf MSSK static4.0.0.0/32 is subnetted, 1 subnets

    S 4.4.4.4 [1/0] via 192.168.34.4

    R3#sh bgp vpnv4 unicast all summary

    BGP router identifier 3.3.3.3, local AS number 1BGP table version is 277, main routing table version 2774 network entries using 560 bytes of memory

    4 path entries using 272 bytes of memory5/4 BGP path/bestpath attribute entries using 620 bytes of memory1 BGP extended community entries using 24 bytes of memory0 BGP route-map cache entries using 0 bytes of memory0 BGP filter-list cache entries using 0 bytes of memoryBitfield cache entries: current 1 (at peak 2) using 32 bytes of memory

    BGP using 1508 total bytes of memoryBGP activity 12/8 prefixes, 14/10 paths, scan interval 15 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd10.10.10.10 4 1 2089 4072 277 0 0 2d19h 2

    R3#sh bgp vpnv4 unicast allBGP table version is 277, local router ID is 3.3.3.3Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

    r RIB-failure, S StaleOrigin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight PathRoute Distinguisher: 100:1 (default for vrf MSSK)*>i1.1.1.1/32 10.10.10.10 0 100 0 ?*> 4.4.4.4/32 192.168.34.4 0 32768 ?*> 192.168.34.0 0.0.0.0 0 32768 i

    *>i192.168.102.0 10.10.10.10 0 100 0 i

    R3#sh bgp vpnv4 unicast all neighbors 10.10.10.10 advertised-routes

    BGP table version is 277, local router ID is 3.3.3.3Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

    r RIB-failure, S Stale

    Origin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path

    Route Distinguisher: 100:1 (default for vrf MSSK)*> 4.4.4.4/32 192.168.34.4 0 32768 ?*> 192.168.34.0 0.0.0.0 0 32768 i

    Total number of prefixes 2

    RP/0/0/CPU0:XR1#sh route vrf MSSK static

  • 8/10/2019 IOS XR Workbook

    11/232

    10

    Tue Jun 24 02:12:37.292 UTC

    S 1.1.1.1/32 [1/0] via 192.168.102.1, 00:03:47RP/0/0/CPU0:XR1#sh bgp vpnv4 unicast summaryTue Jun 24 02:12:39.952 UTC

    BGP router identifier 10.10.10.10, local AS number 1BGP generic scan interval 60 secsBGP table state: Active

    Table ID: 0x0 RD version: 0BGP main routing table version 35BGP scan interval 60 secs

    BGP is operating in STANDALONE mode.

    Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVerSpeaker 35 35 35 35 35 35

    Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd3.3.3.3 0 1 4073 2089 35 0 0 1d10h 2

    RP/0/0/CPU0:XR1#sh bgp vpnv4 unicastTue Jun 24 02:12:41.002 UTCBGP router identifier 10.10.10.10, local AS number 1BGP generic scan interval 60 secsBGP table state: ActiveTable ID: 0x0 RD version: 0

    BGP main routing table version 35BGP scan interval 60 secs

    Status codes: s suppressed, d damped, h history, * valid, > besti - internal, r RIB-failure, S stale, N Nexthop-discard

    Origin codes: i - IGP, e - EGP, ? - incompleteNetwork Next Hop Metric LocPrf Weight Path

    Route Distinguisher: 100:1 (default for vrf MSSK)

    *> 1.1.1.1/32 192.168.102.1 0 32768 ?*>i4.4.4.4/32 3.3.3.3 0 100 0 ?*>i192.168.34.0/24 3.3.3.3 0 100 0 i

    *> 192.168.102.0/24 0.0.0.0 0 32768 i

    Processed 4 prefixes, 4 paths

    RP/0/0/CPU0:XR1#sh bgp vpnv4 unicast neighbors 3.3.3.3 advertised-routesTue Jun 24 02:12:43.012 UTC

    Network Next Hop From AS PathRoute Distinguisher: 100:11.1.1.1/32 10.10.10.10 Local ?192.168.102.0/24 10.10.10.10 Local i

  • 8/10/2019 IOS XR Workbook

    12/232

    11

    Processed 2 prefixes, 2 paths

    R3#debug mpls packetsMPLS packet debugging is on

    R3#*Mar 1 03:40:12.883: MPLS: Fa0/0: recvd: CoS=0, TTL=253, Label(s)=19*Mar 1 03:40:12.883: MPLS: Fa0/1: xmit: (no label)

    *Mar 1 03:40:13.011: MPLS: Fa0/0: recvd: CoS=0, TTL=253, Label(s)=19*Mar 1 03:40:13.011: MPLS: Fa0/1: xmit: (no label)*Mar 1 03:40:13.083: MPLS: Fa0/0: recvd: CoS=0, TTL=253, Label(s)=19*Mar 1 03:40:13.083: MPLS: Fa0/1: xmit: (no label)*Mar 1 03:40:13.151: MPLS: Fa0/0: recvd: CoS=0, TTL=253, Label(s)=19*Mar 1 03:40:13.151: MPLS: Fa0/1: xmit: (no label)

    *Mar 1 03:40:13.207: MPLS: Fa0/0: recvd: CoS=0, TTL=253, Label(s)=19*Mar 1 03:40:13.207: MPLS: Fa0/1: xmit: (no label)

  • 8/10/2019 IOS XR Workbook

    13/232

    12

    MPLS L3VPN RIPv2 PE-CE

    Network Diagram

    XR1

    R2

    R3

    192.168.102.0/24

    192.168.101.0/24 192.168.23.0/24

    192.168.34.0/24

    OSPF A0

    AS1

    Lo0 1.1.1.1/32

    Lo0 3.3.3.3/32

    Lo0 4.4.4.4/32

    10.10.10.10/32

    Lo0 2.2.2.2/32

    RIPv2

    R1

    RIPv2

    R4

    Initial Configurations

    R1interface Loopback0ip address 1.1.1.1 255.255.255.255

    interface FastEthernet0/0ip address 192.168.102.1 255.255.255.0duplex autospeed auto

    no shutdown

    R2interface Loopback0

    ip address 2.2.2.2 255.255.255.255

    interface FastEthernet0/0

    ip address 192.168.101.2 255.255.255.0duplex auto

  • 8/10/2019 IOS XR Workbook

    14/232

    13

    speed autompls ip

    no shutdown

    interface FastEthernet0/1

    ip address 192.168.23.2 255.255.255.0speed 100full-duplex

    mpls ipno shutdown

    R3interface Loopback0ip address 3.3.3.3 255.255.255.255

    interface FastEthernet0/0ip address 192.168.23.3 255.255.255.0

    speed 100full-duplexmpls ip

    no shutdown

    interface FastEthernet0/1ip address 192.168.34.3 255.255.255.0speed 100full-duplex

    no shutdown

    R4interface Loopback0ip address 4.4.4.4 255.255.255.255

    interface FastEthernet0/0ip address 192.168.34.4 255.255.255.0

    speed 100full-duplexno shutdown

    XR1interface Loopback0

    ipv4 address 10.10.10.10 255.255.255.0

    interface GigabitEthernet0/0/0/0

    cdpipv4 address 192.168.102.10 255.255.255.0duplex fullno shutdown

  • 8/10/2019 IOS XR Workbook

    15/232

  • 8/10/2019 IOS XR Workbook

    16/232

    15

    Configurations

    R1router ripversion 2network 1.0.0.0network 192.168.102.0

    no auto-summary

    R2

    router ospf 1router-id 2.2.2.2network 2.2.2.2 0.0.0.0 area 0

    network 192.168.23.2 0.0.0.0 area 0

    network 192.168.101.2 0.0.0.0 area 0

    mpls label protocol ldpmpls ldp router-id Loopback0 force

    interface FastEthernet0/0mpls ip

    interface FastEthernet0/1mpls ip

    R4

    router ripversion 2

    network 4.0.0.0network 192.168.34.0no auto-summary

    R3ip vrf MSSK

    rd 100:1route-target export 100:1route-target import 100:1

    mpls label protocol ldpmpls ldp router-id Loopback0 force

    interface FastEthernet0/0

    mpls ip

    router ospf 1

    router-id 3.3.3.3network 3.3.3.3 0.0.0.0 area 0

  • 8/10/2019 IOS XR Workbook

    17/232

    16

    network 192.168.23.3 0.0.0.0 area 0

    router rip

    address-family ipv4 vrf MSSK

    redistribute bgp 1 metric 1network 192.168.34.0no auto-summary

    version 2exit-address-family

    router bgp 1no bgp default ipv4-unicastbgp log-neighbor-changes

    neighbor 10.10.10.10 remote-as 1neighbor 10.10.10.10 update-source Loopback0

    address-family vpnv4neighbor 10.10.10.10 activateneighbor 10.10.10.10 send-community both

    exit-address-family

    address-family ipv4 vrf MSSKredistribute rip

    XR1

    vrf MSSKaddress-family ipv4 unicastimport route-target100:1

    export route-target100:1

    interface GigabitEthernet0/0/0/0vrf MSSKipv4 address 192.168.102.10 255.255.255.0

    router ospf 1router-id 10.10.10.10

    area 0interface Loopback0

    interface GigabitEthernet0/0/0/2

    router ripvrf MSSK

  • 8/10/2019 IOS XR Workbook

    18/232

    17

    interface GigabitEthernet0/0/0/0

    redistribute bgp 1

    router bgp 1

    address-family vpnv4 unicast

    neighbor 3.3.3.3

    remote-as 1update-source Loopback0address-family vpnv4 unicast

    vrf MSSKrd 100:1

    address-family ipv4 unicastredistribute rip

    mpls ldprouter-id 10.10.10.10interface GigabitEthernet0/0/0/2

    Verifications

    R1#sh ip route rip4.0.0.0/32 is subnetted, 1 subnets

    R 4.4.4.4 [120/2] via 192.168.102.10, 00:00:41, FastEthernet0/0

    R 192.168.34.0/24 [120/1] via 192.168.102.10, 00:00:41, FastEthernet0/0

    R1#ping 4.4.4.4 source lo0

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:Packet sent with a source address of 1.1.1.1!!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 568/748/848 ms

    R1#traceroute 4.4.4.4 source lo0 numeric

    Type escape sequence to abort.Tracing the route to 4.4.4.4

    1 192.168.102.10 4 msec 188 msec 208 msec

    2 192.168.101.2 [MPLS: Labels 16/21 Exp 0] 752 msec 752 msec 752 msec3 192.168.34.3 [MPLS: Label 21 Exp 0] 572 msec 560 msec 564 msec4 192.168.34.4 748 msec 788 msec 664 msec

    R4#sh ip route rip

  • 8/10/2019 IOS XR Workbook

    19/232

  • 8/10/2019 IOS XR Workbook

    20/232

  • 8/10/2019 IOS XR Workbook

    21/232

    20

    Table ID: 0x0 RD version: 0BGP main routing table version 25

    BGP scan interval 60 secs

    Status codes: s suppressed, d damped, h history, * valid, > best

    i - internal, r RIB-failure, S stale, N Nexthop-discardOrigin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path

    Route Distinguisher: 100:1 (default for vrf MSSK)*> 1.1.1.1/32 192.168.102.1 1 32768 ?*>i4.4.4.4/32 3.3.3.3 1 100 0 ?*>i192.168.34.0/24 3.3.3.3 0 100 0 ?*> 192.168.102.0/24 0.0.0.0 0 32768 ?

    Processed 4 prefixes, 4 pathsRP/0/0/CPU0:XR1#sh bgp vpnv4 unicast neighbors 3.3.3.3 advertised-routesSun Jun 22 15:56:29.873 UTC

    Network Next Hop From AS PathRoute Distinguisher: 100:11.1.1.1/32 10.10.10.10 Local ?

    192.168.102.0/24 10.10.10.10 Local ?

    Processed 2 prefixes, 2 paths

  • 8/10/2019 IOS XR Workbook

    22/232

    21

    MPLS L3VPN OSPF PE-CE

    Network Diagram

    XR1

    R2

    R3

    192.168.102.0/24

    192.168.101.0/24 192.168.23.0/24

    192.168.34.0/24

    OSPF A0

    AS1

    Lo0 1.1.1.1/32

    Lo0 3.3.3.3/32

    Lo0 4.4.4.4/32

    10.10.10.10/32

    Lo0 2.2.2.2/32

    OSPF

    R1

    OSPF

    R4

    Initial Configurations

    R1interface Loopback0ip address 1.1.1.1 255.255.255.255

    interface FastEthernet0/0ip address 192.168.102.1 255.255.255.0duplex autospeed auto

    no shutdown

    R2interface Loopback0

    ip address 2.2.2.2 255.255.255.255

    interface FastEthernet0/0

    ip address 192.168.101.2 255.255.255.0duplex auto

  • 8/10/2019 IOS XR Workbook

    23/232

    22

    speed autompls ip

    no shutdown

    interface FastEthernet0/1

    ip address 192.168.23.2 255.255.255.0speed 100full-duplex

    mpls ipno shutdown

    R3interface Loopback0ip address 3.3.3.3 255.255.255.255

    interface FastEthernet0/0ip address 192.168.23.3 255.255.255.0

    speed 100full-duplexmpls ip

    no shutdown

    interface FastEthernet0/1ip address 192.168.34.3 255.255.255.0speed 100full-duplex

    no shutdown

    R4interface Loopback0ip address 4.4.4.4 255.255.255.255

    interface FastEthernet0/0ip address 192.168.34.4 255.255.255.0

    speed 100full-duplexno shutdown

    XR1interface Loopback0

    ipv4 address 10.10.10.10 255.255.255.0

    interface GigabitEthernet0/0/0/0

    cdpipv4 address 192.168.102.10 255.255.255.0duplex fullno shutdown

  • 8/10/2019 IOS XR Workbook

    24/232

    23

    interface GigabitEthernet0/0/0/2

    cdpipv4 address 192.168.101.10 255.255.255.0no shutdown

  • 8/10/2019 IOS XR Workbook

    25/232

    24

    Configurations

    R1router ospf 2router-id 1.1.1.1log-adjacency-changesnetwork 1.1.1.1 0.0.0.0 area 0

    network 192.168.102.1 0.0.0.0 area 0

    R2

    router ospf 1router-id 2.2.2.2network 2.2.2.2 0.0.0.0 area 0

    network 192.168.23.2 0.0.0.0 area 0

    network 192.168.101.2 0.0.0.0 area 0

    mpls label protocol ldpmpls ldp router-id Loopback0 force

    interface FastEthernet0/0mpls ip

    interface FastEthernet0/1mpls ip

    R4

    router ospf 2router-id 4.4.4.4

    log-adjacency-changesnetwork 4.4.4.4 0.0.0.0 area 0network 192.168.34.4 0.0.0.0 area 0

    R3ip vrf MSSK

    rd 100:1route-target export 100:1route-target import 100:1

    mpls label protocol ldpmpls ldp router-id Loopback0 force

    interface FastEthernet0/0

    mpls ip

    router ospf 1

    router-id 3.3.3.3network 3.3.3.3 0.0.0.0 area 0

  • 8/10/2019 IOS XR Workbook

    26/232

    25

    network 192.168.23.3 0.0.0.0 area 0

    router ospf 2 vrf MSSKredistribute bgp 1 subnetsnetwork 192.168.34.3 0.0.0.0 area 0

    router bgp 1no bgp default ipv4-unicast

    bgp log-neighbor-changesneighbor 10.10.10.10 remote-as 1neighbor 10.10.10.10 update-source Loopback0

    address-family vpnv4neighbor 10.10.10.10 activate

    neighbor 10.10.10.10 send-community bothexit-address-family

    address-family ipv4 vrf MSSKredistribute ospf 2 vrf MSSKno synchronization

    exit-address-family

    XR1vrf MSSKaddress-family ipv4 unicastimport route-target

    100:1

    export route-target100:1

    interface GigabitEthernet0/0/0/0vrf MSSKipv4 address 192.168.102.10 255.255.255.0

    router ospf 1router-id 10.10.10.10

    area 0

    interface Loopback0

    interface GigabitEthernet0/0/0/2

    router ospf 2

    vrf MSSKredistribute bgp 1area 0interface GigabitEthernet0/0/0/0

  • 8/10/2019 IOS XR Workbook

    27/232

    26

    router bgp 1

    address-family vpnv4 unicast

    neighbor 3.3.3.3

    remote-as 1update-source Loopback0address-family vpnv4 unicast

    vrf MSSKrd 100:1address-family ipv4 unicastredistribute ospf 2

    mpls ldprouter-id 10.10.10.10interface GigabitEthernet0/0/0/2

    Verifications

    R1#sh ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface10.10.10.10 1 FULL/BDR 00:00:38 192.168.102.10 FastEthernet0/0

    R1#sh ip route ospf

    4.0.0.0/32 is subnetted, 1 subnetsO E2 4.4.4.4 [110/2] via 192.168.102.10, 00:45:30, FastEthernet0/0

    O E2 192.168.34.0/24 [110/1] via 192.168.102.10, 00:45:30, FastEthernet0/0

    R1#sh ip ospf database

    OSPF Router with ID (1.1.1.1) (Process ID 2)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link count

    1.1.1.1 1.1.1.1 724 0x8000000A 0x00AFB2 2

    10.10.10.10 10.10.10.10 2555 0x80000009 0x000825 1

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum192.168.102.1 1.1.1.1 724 0x80000008 0x0069C8

    Type-5 AS External Link States

  • 8/10/2019 IOS XR Workbook

    28/232

    27

    Link ID ADV Router Age Seq# Checksum Tag4.4.4.4 10.10.10.10 2555 0x80000008 0x00061B 3489660929

    192.168.34.0 10.10.10.10 2555 0x80000008 0x008B1B 3489660929

    R1#ping 4.4.4.4 source lo0

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

    Packet sent with a source address of 1.1.1.1!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 480/649/756 ms

    R1#traceroute 4.4.4.4 source lo0 numeric

    Type escape sequence to abort.Tracing the route to 4.4.4.4

    1 192.168.102.10 36 msec 88 msec 188 msec2 192.168.101.2 [MPLS: Labels 16/19 Exp 0] 664 msec 752 msec 660 msec3 192.168.34.3 [MPLS: Label 19 Exp 0] 376 msec 472 msec 376 msec

    4 192.168.34.4 848 msec 660 msec 656 msec

    R4#sh ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface192.168.34.3 1 FULL/DR 00:00:35 192.168.34.3 FastEthernet0/0

    R4#sh ip route ospf1.0.0.0/32 is subnetted, 1 subnets

    O E2 1.1.1.1 [110/2] via 192.168.34.3, 00:54:14, FastEthernet0/0O E2 192.168.102.0/24 [110/1] via 192.168.34.3, 00:54:14, FastEthernet0/0

    R4#sh ip ospf database

    OSPF Router with ID (4.4.4.4) (Process ID 2)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link count4.4.4.4 4.4.4.4 860 0x8000000A 0x007F4B 2

    192.168.34.3 192.168.34.3 748 0x8000000A 0x00806C 1

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum192.168.34.3 192.168.34.3 1000 0x80000008 0x00E195

  • 8/10/2019 IOS XR Workbook

    29/232

    28

    Type-5 AS External Link States

    Link ID ADV Router Age Seq# Checksum Tag1.1.1.1 192.168.34.3 1255 0x80000002 0x004409 3489660929192.168.102.0 192.168.34.3 1255 0x80000002 0x005032 3489660929

    R4#ping 1.1.1.1 source lo0

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:Packet sent with a source address of 4.4.4.4!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 472/607/672 ms

    R4#traceroute 1.1.1.1 source lo0 numeric

    Type escape sequence to abort.

    Tracing the route to 1.1.1.1

    1 192.168.34.3 228 msec 184 msec 184 msec

    2 192.168.23.2 [MPLS: Labels 17/16003 Exp 0] 660 msec 660 msec 664 msec3 192.168.101.10 [MPLS: Label 16003 Exp 0] 752 msec 660 msec 660 msec4 192.168.102.1 560 msec 660 msec 596 msec

    R3#sh ip route vrf MSSK ospf

    Routing Table: MSSK

    4.0.0.0/32 is subnetted, 1 subnetsO 4.4.4.4 [110/2] via 192.168.34.4, 04:11:44, FastEthernet0/1

    R3#sh bgp vpnv4 unicast all summaryBGP router identifier 3.3.3.3, local AS number 1BGP table version is 21, main routing table version 21

    4 network entries using 560 bytes of memory4 path entries using 272 bytes of memory5/4 BGP path/bestpath attribute entries using 620 bytes of memory

    3 BGP extended community entries using 120 bytes of memory

    0 BGP route-map cache entries using 0 bytes of memory0 BGP filter-list cache entries using 0 bytes of memory

    Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memoryBGP using 1604 total bytes of memoryBGP activity 4/0 prefixes, 4/0 paths, scan interval 15 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd10.10.10.10 4 1 129 255 21 0 0 04:08:31 2

  • 8/10/2019 IOS XR Workbook

    30/232

    29

    R3#sh bgp vpnv4 unicast allBGP table version is 21, local router ID is 3.3.3.3

    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,r RIB-failure, S StaleOrigin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight PathRoute Distinguisher: 100:1 (default for vrf MSSK)

    *>i1.1.1.1/32 10.10.10.10 2 100 0 ?*> 4.4.4.4/32 192.168.34.4 2 32768 ?*> 192.168.34.0 0.0.0.0 0 32768 ?*>i192.168.102.0 10.10.10.10 0 100 0 ?

    R3#sh bgp vpnv4 unicast all neighbors 10.10.10.10 advertised-routes

    BGP table version is 21, local router ID is 3.3.3.3Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,r RIB-failure, S Stale

    Origin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path

    Route Distinguisher: 100:1 (default for vrf MSSK)*> 4.4.4.4/32 192.168.34.4 2 32768 ?*> 192.168.34.0 0.0.0.0 0 32768 ?

    Total number of prefixes 2

    R3#sh ip vrfName Default RD InterfacesMSSK 100:1 Fa0/1

    RP/0/0/CPU0:XR1#sh route vrf MSSK ospf

    Thu Jun 19 12:52:32.714 UTC

    O 1.1.1.1/32 [110/2] via 192.168.102.1, 02:03:06, GigabitEthernet0/0/0/0

    RP/0/0/CPU0:XR1#sh bgp vpnv4 unicast summaryThu Jun 19 12:52:36.424 UTC

    BGP router identifier 10.10.10.10, local AS number 1

    BGP generic scan interval 60 secsBGP table state: Active

    Table ID: 0x0 RD version: 0BGP main routing table version 10BGP scan interval 60 secs

    BGP is operating in STANDALONE mode.

  • 8/10/2019 IOS XR Workbook

    31/232

    30

    Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVerSpeaker 10 10 10 10 10 10

    Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd3.3.3.3 0 1 256 129 10 0 0 02:05:46 2

    RP/0/0/CPU0:XR1#sh bgp vpnv4 unicastThu Jun 19 12:52:37.074 UTC

    BGP router identifier 10.10.10.10, local AS number 1BGP generic scan interval 60 secsBGP table state: ActiveTable ID: 0x0 RD version: 0BGP main routing table version 10BGP scan interval 60 secs

    Status codes: s suppressed, d damped, h history, * valid, > besti - internal, r RIB-failure, S stale, N Nexthop-discard

    Origin codes: i - IGP, e - EGP, ? - incompleteNetwork Next Hop Metric LocPrf Weight Path

    Route Distinguisher: 100:1 (default for vrf MSSK)

    *> 1.1.1.1/32 192.168.102.1 2 32768 ?*>i4.4.4.4/32 3.3.3.3 2 100 0 ?*>i192.168.34.0/24 3.3.3.3 0 100 0 ?*> 192.168.102.0/24 0.0.0.0 0 32768 ?

    Processed 4 prefixes, 4 paths

    RP/0/0/CPU0:XR1#sh bgp vpnv4 unicast neighbors 3.3.3.3 advertised-routesThu Jun 19 12:52:39.094 UTCNetwork Next Hop From AS PathRoute Distinguisher: 100:1

    1.1.1.1/32 10.10.10.10 Local ?192.168.102.0/24 10.10.10.10 Local ?

    Processed 2 prefixes, 2 pathsRP/0/0/CPU0:XR1#sh vrf MSSKThu Jun 19 12:52:41.274 UTC

    VRF RD RT AFI SAFI

    MSSK 100:1 import 100:1 IPV4 Unicast

    export 100:1 IPV4 Unicast

  • 8/10/2019 IOS XR Workbook

    32/232

    31

    MPLS L3VPN OSPF Sham-link

    Network Diagram

    OSPF OSPF

    XR1

    R2

    R3

    192.168.102.0/24

    192.168.101.0/24 192.168.23.0/24

    192.168.34.0/24

    OSPF A0

    AS1

    AS200

    Lo0 1.1.1.1/32

    Lo0 3.3.3.3/32

    Lo0 4.4.4.4/32

    10.10.10.10/32

    Lo0 2.2.2.2/32

    R4

    1

    192.168.14.0/24

    Initial Configurations

    R1interface Loopback0ip address 1.1.1.1 255.255.255.255

    interface FastEthernet0/0ip address 192.168.102.1 255.255.255.0

    duplex autospeed autono shutdown

    interface FastEthernet0/0ip address 192.168.14.1 255.255.255.0

    speed 100full-duplexno shutdown

    R2interface Loopback0ip address 2.2.2.2 255.255.255.255

  • 8/10/2019 IOS XR Workbook

    33/232

    32

    interface FastEthernet0/0ip address 192.168.101.2 255.255.255.0

    duplex autospeed autompls ip

    no shutdown

    interface FastEthernet0/1

    ip address 192.168.23.2 255.255.255.0speed 100full-duplexmpls ipno shutdown

    R3interface Loopback0ip address 3.3.3.3 255.255.255.255

    interface FastEthernet0/0ip address 192.168.23.3 255.255.255.0

    speed 100full-duplexmpls ipno shutdown

    interface FastEthernet0/1

    ip address 192.168.34.3 255.255.255.0speed 100full-duplexno shutdown

    R4interface Loopback0ip address 4.4.4.4 255.255.255.255

    interface FastEthernet0/0ip address 192.168.34.4 255.255.255.0

    speed 100

    full-duplexno shutdown

    interface FastEthernet0/1ip address 192.168.14.4 255.255.255.0

    speed 100full-duplexno shutdown

  • 8/10/2019 IOS XR Workbook

    34/232

    33

    XR1

    interface Loopback0ipv4 address 10.10.10.10 255.255.255.0

    interface GigabitEthernet0/0/0/0cdpipv4 address 192.168.102.10 255.255.255.0

    duplex fullno shutdown

    interface GigabitEthernet0/0/0/2cdpipv4 address 192.168.101.10 255.255.255.0

    no shutdown

  • 8/10/2019 IOS XR Workbook

    35/232

    34

    Configurations

    Now, we have connected a new link between the CEs with the subnet 192.168.14.0/24

    Let us check what happened

    R1#sh ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface4.4.4.4 1 FULL/DR 00:00:34 192.168.14.4 FastEthernet0/1

    10.10.10.10 1 FULL/BDR 00:00:36 192.168.102.10 FastEthernet0/0

    R1#sh ip route ospf

    4.0.0.0/32 is subnetted, 1 subnets

    O 4.4.4.4 [110/2] via 192.168.14.4, 00:01:30, FastEthernet0/1O 192.168.34.0/24 [110/2] via 192.168.14.4, 00:01:30, FastEthernet0/1

    We can see now that R1 prefers the backdoor link to reach R4 loopback 0 network

    R4#sh ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface1.1.1.1 1 FULL/BDR 00:00:38 192.168.14.1 FastEthernet0/1192.168.34.3 1 FULL/DR 00:00:39 192.168.34.3 FastEthernet0/0

    R4#sh ip route ospf

    1.0.0.0/32 is subnetted, 1 subnetsO 1.1.1.1 [110/2] via 192.168.14.1, 00:02:00, FastEthernet0/1

    O 192.168.102.0/24 [110/11] via 192.168.14.1, 00:02:00, FastEthernet0/1

    R1#traceroute 4.4.4.4 source lo0

    Type escape sequence to abort.Tracing the route to 4.4.4.4

    1 192.168.14.4 32 msec 64 msec 60 msec

    R1#sh ip ospf database

    OSPF Router with ID (1.1.1.1) (Process ID 2)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link count1.1.1.1 1.1.1.1 200 0x80000005 0x00B2B0 3

    4.4.4.4 4.4.4.4 201 0x80000005 0x00A622 310.10.10.10 10.10.10.10 546 0x80000003 0x00141F 1

  • 8/10/2019 IOS XR Workbook

    36/232

    35

    192.168.34.3 192.168.34.3 613 0x80000003 0x008E65 1

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum

    192.168.14.4 4.4.4.4 201 0x80000001 0x006D2D192.168.34.3 192.168.34.3 793 0x80000001 0x00EF8E192.168.102.1 1.1.1.1 797 0x80000001 0x0077C1

    R4#traceroute 1.1.1.1 source lo0

    Type escape sequence to abort.Tracing the route to 1.1.1.1

    1 192.168.14.1 60 msec 60 msec 64 msec

    R4#sh ip ospf database

    OSPF Router with ID (4.4.4.4) (Process ID 2)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link count1.1.1.1 1.1.1.1 253 0x80000005 0x00B2B0 34.4.4.4 4.4.4.4 252 0x80000005 0x00A622 3

    10.10.10.10 10.10.10.10 597 0x80000003 0x00141F 1192.168.34.3 192.168.34.3 664 0x80000003 0x008E65 1

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum192.168.14.4 4.4.4.4 252 0x80000001 0x006D2D192.168.34.3 192.168.34.3 844 0x80000001 0x00EF8E

    192.168.102.1 1.1.1.1 849 0x80000001 0x0077C1

    R1

    interface FastEthernet0/1

    ip address 192.168.14.1 255.255.255.0ip ospf cost 1000

    ip ospf 2 area 0speed 100full-duplex

    R4interface FastEthernet0/1ip address 192.168.14.4 255.255.255.0

  • 8/10/2019 IOS XR Workbook

    37/232

  • 8/10/2019 IOS XR Workbook

    38/232

    37

    router bgp 1address-family vpnv4 unicast

    neighbor 3.3.3.3remote-as 1

    update-source Loopback0address-family vpnv4 unicast

    vrf MSSKrd 100:1address-family ipv4 unicastnetwork 11.11.11.11/32redistribute ospf 2

    R3#sh ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface

    2.2.2.2 0 FULL/ - 00:00:34 192.168.23.2 FastEthernet0/010.10.10.10 0 FULL/ - - 11.11.11.11 OSPF_SL04.4.4.4 1 FULL/DR 00:00:39 192.168.34.4 FastEthernet0/1

    RP/0/0/CPU0:XR1#sh ospf vrf MSSK neighborSun Apr 27 14:19:16.598 UTC

    * Indicates MADJ interface

    Neighbors for OSPF 2, VRF MSSK

    Neighbor ID Pri State Dead Time Address Interface192.168.34.3 1 FULL/ - - 33.33.33.33 OSPF_SL0

    Neighbor is up for 00:03:14

    1.1.1.1 1 FULL/BDR 00:00:39 192.168.102.1 GigabitEthernet0/0/0/0Neighbor is up for 00:03:49

    Total neighbor count: 2

    R1#sh ip route ospf

    33.0.0.0/32 is subnetted, 1 subnets

    O E2 33.33.33.33 [110/1] via 192.168.102.10, 00:03:56, FastEthernet0/04.0.0.0/32 is subnetted, 1 subnets

    O 4.4.4.4 [110/13] via 192.168.102.10, 00:03:30, FastEthernet0/011.0.0.0/32 is subnetted, 1 subnets

    O E2 11.11.11.11 [110/1] via 192.168.102.10, 00:03:30, FastEthernet0/0

    O 192.168.34.0/24 [110/12] via 192.168.102.10, 00:03:30, FastEthernet0/0

    R1#ping 4.4.4.4 source lo0

  • 8/10/2019 IOS XR Workbook

    39/232

    38

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

    Packet sent with a source address of 1.1.1.1!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 32/76/124 ms

    R1#traceroute 4.4.4.4 source lo0

    Type escape sequence to abort.Tracing the route to 4.4.4.4

    1 192.168.102.10 32 msec 64 msec 0 msec2 192.168.101.2 [MPLS: Labels 17/25 Exp 0] 68 msec 52 msec 44 msec3 192.168.34.3 [MPLS: Label 25 Exp 0] 52 msec 64 msec 32 msec

    4 192.168.34.4 64 msec 64 msec 64 msec

    R1#sh ip ospf database

    OSPF Router with ID (1.1.1.1) (Process ID 2)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link count1.1.1.1 1.1.1.1 267 0x80000009 0x00F278 34.4.4.4 4.4.4.4 267 0x8000000A 0x0034A3 310.10.10.10 10.10.10.10 232 0x8000000C 0x00245D 2

    192.168.34.3 192.168.34.3 233 0x80000006 0x005D4F 2

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum

    192.168.14.4 4.4.4.4 272 0x80000001 0x006D2D192.168.34.4 4.4.4.4 272 0x80000001 0x007487192.168.102.10 10.10.10.10 264 0x80000003 0x000AFF

    Type-5 AS External Link States

    Link ID ADV Router Age Seq# Checksum Tag

    11.11.11.11 192.168.34.3 243 0x80000001 0x006EB8 348966092933.33.33.33 10.10.10.10 262 0x80000005 0x004EE2 3489660929

    33.33.33.33 192.168.34.3 267 0x80000003 0x00725A 3489660929

    R4#sh ip route ospf

    1.0.0.0/32 is subnetted, 1 subnetsO 1.1.1.1 [110/4] via 192.168.34.3, 00:03:58, FastEthernet0/0

    33.0.0.0/32 is subnetted, 1 subnetsO E2 33.33.33.33 [110/1] via 192.168.34.3, 00:04:24, FastEthernet0/0

  • 8/10/2019 IOS XR Workbook

    40/232

    39

    11.0.0.0/32 is subnetted, 1 subnetsO E2 11.11.11.11 [110/1] via 192.168.34.3, 00:04:13, FastEthernet0/0

    O 192.168.102.0/24 [110/3] via 192.168.34.3, 00:03:58, FastEthernet0/0R4#ping 1.1.1.1 source lo0

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:Packet sent with a source address of 4.4.4.4

    !!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 160/192/224 ms

    R4#traceroute 1.1.1.1 source lo0

    Type escape sequence to abort.

    Tracing the route to 1.1.1.1

    1 192.168.34.3 68 msec 40 msec 64 msec

    2 192.168.23.2 [MPLS: Labels 16/16004 Exp 0] 176 msec 176 msec 192 msec3 192.168.101.10 [MPLS: Label 16004 Exp 0] 216 msec 160 msec 192 msec4 192.168.102.1 180 msec 192 msec 184 msec

    R4#sh ip ospf database

    OSPF Router with ID (4.4.4.4) (Process ID 2)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link count1.1.1.1 1.1.1.1 294 0x80000009 0x00F278 34.4.4.4 4.4.4.4 293 0x8000000A 0x0034A3 310.10.10.10 10.10.10.10 260 0x8000000C 0x00245D 2

    192.168.34.3 192.168.34.3 258 0x80000006 0x005D4F 2

    Net Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum192.168.14.4 4.4.4.4 298 0x80000001 0x006D2D

    192.168.34.4 4.4.4.4 298 0x80000001 0x007487

    192.168.102.10 10.10.10.10 291 0x80000003 0x000AFF

    Type-5 AS External Link States

    Link ID ADV Router Age Seq# Checksum Tag

    11.11.11.11 192.168.34.3 269 0x80000001 0x006EB8 348966092933.33.33.33 10.10.10.10 290 0x80000005 0x004EE2 348966092933.33.33.33 192.168.34.3 293 0x80000003 0x00725A 3489660929

  • 8/10/2019 IOS XR Workbook

    41/232

    40

    R1#sh ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface4.4.4.4 1 FULL/DR 00:00:37 192.168.14.4 FastEthernet0/110.10.10.10 1 FULL/DR 00:00:39 192.168.102.10 FastEthernet0/0

    R4#sh ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface1.1.1.1 1 FULL/BDR 00:00:36 192.168.14.1 FastEthernet0/1192.168.34.3 1 FULL/BDR 00:00:32 192.168.34.3 FastEthernet0/0

    R1#sh ip ospf interface fastEthernet 0/1 | inc CostProcess ID 2, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1000

    R4#sh ip ospf interface fastEthernet 0/1 | inc CostProcess ID 2, Router ID 4.4.4.4, Network Type BROADCAST, Cost: 1000

  • 8/10/2019 IOS XR Workbook

    42/232

    41

    MPLS L3VPN EIGRP PE-CE

    Network Diagram

    XR1

    R2

    R3

    192.168.102.0/24

    192.168.101.0/24 192.168.23.0/24

    192.168.34.0/24

    OSPF A0

    AS1

    Lo0 1.1.1.1/32

    Lo0 3.3.3.3/32

    Lo0 4.4.4.4/32

    10.10.10.10/32

    Lo0 2.2.2.2/32

    EIGRP

    R1

    EIGRP

    R4

    Initial Configurations

    R1interface Loopback0ip address 1.1.1.1 255.255.255.255

    interface FastEthernet0/0ip address 192.168.102.1 255.255.255.0duplex autospeed auto

    no shutdown

    R2interface Loopback0

    ip address 2.2.2.2 255.255.255.255

    interface FastEthernet0/0

    ip address 192.168.101.2 255.255.255.0duplex auto

  • 8/10/2019 IOS XR Workbook

    43/232

    42

    speed autompls ip

    no shutdown

    interface FastEthernet0/1

    ip address 192.168.23.2 255.255.255.0speed 100full-duplex

    mpls ipno shutdown

    R3interface Loopback0ip address 3.3.3.3 255.255.255.255

    interface FastEthernet0/0ip address 192.168.23.3 255.255.255.0

    speed 100full-duplexmpls ip

    no shutdown

    interface FastEthernet0/1ip address 192.168.34.3 255.255.255.0speed 100full-duplex

    no shutdown

    R4interface Loopback0ip address 4.4.4.4 255.255.255.255

    interface FastEthernet0/0ip address 192.168.34.4 255.255.255.0

    speed 100full-duplexno shutdown

    XR1interface Loopback0

    ipv4 address 10.10.10.10 255.255.255.0

    interface GigabitEthernet0/0/0/0

    cdpipv4 address 192.168.102.10 255.255.255.0duplex fullno shutdown

  • 8/10/2019 IOS XR Workbook

    44/232

    43

    interface GigabitEthernet0/0/0/2

    cdpipv4 address 192.168.101.10 255.255.255.0no shutdown

  • 8/10/2019 IOS XR Workbook

    45/232

    44

    Configurations

    R1router eigrp 100network 1.1.1.1 0.0.0.0network 192.168.102.1 0.0.0.0no auto-summary

    R2router ospf 1

    router-id 2.2.2.2network 2.2.2.2 0.0.0.0 area 0network 192.168.23.2 0.0.0.0 area 0

    network 192.168.101.2 0.0.0.0 area 0

    mpls label protocol ldp

    mpls ldp router-id Loopback0 force

    interface FastEthernet0/0mpls ip

    interface FastEthernet0/1mpls ip

    R4

    router eigrp 100

    network 4.4.4.4 0.0.0.0network 192.168.34.4 0.0.0.0

    no auto-summary

    R3

    ip vrf MSSKrd 100:1route-target export 100:1

    route-target import 100:1

    mpls label protocol ldp

    mpls ldp router-id Loopback0 force

    interface FastEthernet0/0mpls ip

    router ospf 1router-id 3.3.3.3network 3.3.3.3 0.0.0.0 area 0

    network 192.168.23.3 0.0.0.0 area 0

  • 8/10/2019 IOS XR Workbook

    46/232

    45

    router eigrp 1address-family ipv4 vrf MSSK

    redistribute bgp 1network 192.168.34.3 0.0.0.0default-metric 1000 1000 255 1 1500

    no auto-summaryautonomous-system 100

    router bgp 1no bgp default ipv4-unicastbgp log-neighbor-changesneighbor 10.10.10.10 remote-as 1neighbor 10.10.10.10 update-source Loopback0

    address-family vpnv4neighbor 10.10.10.10 activateneighbor 10.10.10.10 send-community both

    exit-address-family

    address-family ipv4 vrf MSSK

    redistribute eigrp 100

    XR1vrf MSSKaddress-family ipv4 unicastimport route-target

    100:1

    export route-target100:1

    interface GigabitEthernet0/0/0/0vrf MSSKipv4 address 192.168.102.10 255.255.255.0

    router ospf 1router-id 10.10.10.10

    area 0

    interface Loopback0

    interface GigabitEthernet0/0/0/2

    router eigrp 1

    vrf MSSKaddress-family ipv4default-metric 1000 1000 255 1 1500autonomous-system 100

  • 8/10/2019 IOS XR Workbook

    47/232

    46

    redistribute bgp 1interface GigabitEthernet0/0/0/0

    router bgp 1address-family vpnv4 unicast

    neighbor 3.3.3.3remote-as 1

    update-source Loopback0address-family vpnv4 unicast

    vrf MSSKrd 100:1address-family ipv4 unicast

    redistribute eigrp 100

    mpls ldp

    router-id 10.10.10.10interface GigabitEthernet0/0/0/2

    Verifications

    R1#sh ip route eigrp4.0.0.0/32 is subnetted, 1 subnets

    D 4.4.4.4 [90/412160] via 192.168.102.10, 00:01:34, FastEthernet0/0

    D 192.168.34.0/24 [90/284160] via 192.168.102.10, 00:01:34, FastEthernet0/0

    R1#ping 4.4.4.4 source lo0

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

    Packet sent with a source address of 1.1.1.1!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 508/665/936 ms

    R1#traceroute 4.4.4.4 source lo0 numeric

    Type escape sequence to abort.

    Tracing the route to 4.4.4.4

    1 192.168.102.10 192 msec 92 msec 88 msec2 192.168.101.2 [MPLS: Labels 16/19 Exp 0] 692 msec 972 msec 664 msec

    3 192.168.34.3 [MPLS: Label 19 Exp 0] 468 msec 564 msec 372 msec4 192.168.34.4 564 msec 564 msec 784 msec

    R4#sh ip route eigrp1.0.0.0/32 is subnetted, 1 subnets

  • 8/10/2019 IOS XR Workbook

    48/232

    47

    D 1.1.1.1 [90/156416] via 192.168.34.3, 00:01:39, FastEthernet0/0D 192.168.102.0/24 [90/28416] via 192.168.34.3, 00:01:39, FastEthernet0/0

    R4#ping 1.1.1.1 source lo0

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:Packet sent with a source address of 4.4.4.4

    !!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 280/372/448 ms

    R4#traceroute 1.1.1.1 source lo0 numeric

    Type escape sequence to abort.

    Tracing the route to 1.1.1.1

    1 192.168.34.3 36 msec 188 msec 92 msec

    2 192.168.23.2 [MPLS: Labels 17/16003 Exp 0] 468 msec 472 msec 400 msec3 192.168.101.10 [MPLS: Label 16003 Exp 0] 380 msec 280 msec 752 msec4 192.168.102.1 280 msec 472 msec 376 msec

    R3#sh ip eigrp vrf MSSK interfacesIP-EIGRP interfaces for process 100

    Xmit Queue Mean Pacing Time Multicast PendingInterface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

    Fa0/1 1 0/0 298 0/1 1352 0

    R3#sh ip eigrp vrf MSSK neighborsIP-EIGRP neighbors for process 100H Address Interface Hold Uptime SRTT RTO Q Seq

    (sec) (ms) Cnt Num0 192.168.34.4 Fa0/1 10 00:09:17 298 1788 0 3

    R3#sh ip route vrf MSSK eigrp4.0.0.0/32 is subnetted, 1 subnets

    D 4.4.4.4 [90/156160] via 192.168.34.4, 00:09:22, FastEthernet0/1

    R3#sh bgp vpnv4 unicast all summaryBGP router identifier 3.3.3.3, local AS number 1

    BGP table version is 9, main routing table version 94 network entries using 560 bytes of memory4 path entries using 272 bytes of memory

    5/4 BGP path/bestpath attribute entries using 620 bytes of memory4 BGP extended community entries using 240 bytes of memory0 BGP route-map cache entries using 0 bytes of memory0 BGP filter-list cache entries using 0 bytes of memory

  • 8/10/2019 IOS XR Workbook

    49/232

    48

    Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memoryBGP using 1724 total bytes of memory

    BGP activity 4/0 prefixes, 4/0 paths, scan interval 15 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

    10.10.10.10 4 1 11 20 9 0 0 00:12:26 2

    R3#sh bgp vpnv4 unicast all

    BGP table version is 9, local router ID is 3.3.3.3Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

    r RIB-failure, S StaleOrigin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path

    Route Distinguisher: 100:1 (default for vrf MSSK)*>i1.1.1.1/32 10.10.10.10 2570240 100 0 ?*> 4.4.4.4/32 192.168.34.4 156160 32768 ?

    *> 192.168.34.0 0.0.0.0 0 32768 ?*>i192.168.102.0 10.10.10.10 0 100 0 ?

    R3#sh bgp vpnv4 unicast all neighbors 10.10.10.10 advertised-routesBGP table version is 9, local router ID is 3.3.3.3Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

    r RIB-failure, S StaleOrigin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight PathRoute Distinguisher: 100:1 (default for vrf MSSK)*> 4.4.4.4/32 192.168.34.4 156160 32768 ?*> 192.168.34.0 0.0.0.0 0 32768 ?

    Total number of prefixes 2

    RP/0/0/CPU0:XR1#sh eigrp vrf MSSK interfaces

    Sun Jun 22 15:42:32.111 UTC

    IPv4-EIGRP Interfaces for AS(100)

    Xmit Queue Mean Pacing Time Multicast PendingInterface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

    Gi0/0/0/0 1 0/0 69 0/10 320 0

    RP/0/0/CPU0:XR1#sh eigrp vrf MSSK neighbors

    Sun Jun 22 15:42:33.631 UTC

    IPv4-EIGRP Neighbors for AS(100) VRF MSSK

  • 8/10/2019 IOS XR Workbook

    50/232

    49

    H Address Interface Hold Uptime SRTT RTO Q Seq(sec) (ms) Cnt Num

    0 192.168.102.1 Gi0/0/0/0 13 00:02:24 69 414 0 9

    RP/0/0/CPU0:XR1#sh route vrf MSSK eigrp

    Sun Jun 22 15:42:36.431 UTC

    D 1.1.1.1/32 [90/2570240] via 192.168.102.1, 00:02:09, GigabitEthernet0/0/0/0

    RP/0/0/CPU0:XR1#sh bgp vpnv4 unicast summarySun Jun 22 15:42:39.790 UTCBGP router identifier 10.10.10.10, local AS number 1BGP generic scan interval 60 secsBGP table state: ActiveTable ID: 0x0 RD version: 0

    BGP main routing table version 8BGP scan interval 60 secs

    BGP is operating in STANDALONE mode.

    Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer

    Speaker 8 8 8 8 8 8

    Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd3.3.3.3 0 1 21 12 8 0 0 00:07:31 2

    RP/0/0/CPU0:XR1#sh bgp vpnv4 unicast

    Sun Jun 22 15:42:41.700 UTCBGP router identifier 10.10.10.10, local AS number 1BGP generic scan interval 60 secsBGP table state: ActiveTable ID: 0x0 RD version: 0

    BGP main routing table version 8BGP scan interval 60 secs

    Status codes: s suppressed, d damped, h history, * valid, > besti - internal, r RIB-failure, S stale, N Nexthop-discard

    Origin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path

    Route Distinguisher: 100:1 (default for vrf MSSK)*> 1.1.1.1/32 192.168.102.1 2570240 32768 ?

    *>i4.4.4.4/32 3.3.3.3 156160 100 0 ?*>i192.168.34.0/24 3.3.3.3 0 100 0 ?*> 192.168.102.0/24 0.0.0.0 0 32768 ?

    Processed 4 prefixes, 4 pathsRP/0/0/CPU0:XR1#sh bgp vpnv4 unicast neighbors 3.3.3.3 advertised-routesSun Jun 22 15:42:43.790 UTC

  • 8/10/2019 IOS XR Workbook

    51/232

    50

    Network Next Hop From AS PathRoute Distinguisher: 100:1

    1.1.1.1/32 10.10.10.10 Local ?192.168.102.0/24 10.10.10.10 Local ?

    Processed 2 prefixes, 2 paths

  • 8/10/2019 IOS XR Workbook

    52/232

    51

    MPLS L3VPN BGP PE-CE

    Network Diagram

    XR1

    R2

    R3

    192.168.102.0/24

    192.168.101.0/24 192.168.23.0/24

    192.168.34.0/24

    OSPF A0

    AS1

    Lo0 1.1.1.1/32

    Lo0 3.3.3.3/32

    Lo0 4.4.4.4/32

    10.10.10.10/32

    Lo0 2.2.2.2/32

    BGP

    R1

    BGP

    R4

    S2 AS2

    Initial Configurations

    R1interface Loopback0ip address 1.1.1.1 255.255.255.255

    interface FastEthernet0/0ip address 192.168.102.1 255.255.255.0

    duplex autospeed autono shutdown

    R2interface Loopback0ip address 2.2.2.2 255.255.255.255

    interface FastEthernet0/0ip address 192.168.101.2 255.255.255.0

  • 8/10/2019 IOS XR Workbook

    53/232

    52

    duplex autospeed auto

    mpls ipno shutdown

    interface FastEthernet0/1ip address 192.168.23.2 255.255.255.0speed 100

    full-duplexmpls ipno shutdown

    R3interface Loopback0

    ip address 3.3.3.3 255.255.255.255

    interface FastEthernet0/0

    ip address 192.168.23.3 255.255.255.0speed 100full-duplex

    mpls ipno shutdown

    interface FastEthernet0/1ip address 192.168.34.3 255.255.255.0speed 100

    full-duplexno shutdown

    R4interface Loopback0

    ip address 4.4.4.4 255.255.255.255

    interface FastEthernet0/0

    ip address 192.168.34.4 255.255.255.0speed 100full-duplex

    no shutdown

    XR1

    interface Loopback0ipv4 address 10.10.10.10 255.255.255.0

    interface GigabitEthernet0/0/0/0cdpipv4 address 192.168.102.10 255.255.255.0duplex full

  • 8/10/2019 IOS XR Workbook

    54/232

  • 8/10/2019 IOS XR Workbook

    55/232

    54

    Configurations

    R1router bgp 2no bgp default ipv4-unicastneighbor 192.168.102.10 remote-as 1address-family ipv4 unicast

    neighbor 192.168.102.10 activatenetwork 1.1.1.1 mask 255.255.255.255

    R2router ospf 1router-id 2.2.2.2

    network 2.2.2.2 0.0.0.0 area 0

    network 192.168.23.2 0.0.0.0 area 0network 192.168.101.2 0.0.0.0 area 0

    mpls label protocol ldpmpls ldp router-id Loopback0 force

    interface FastEthernet0/0mpls ip

    interface FastEthernet0/1mpls ip

    R4router bgp 2

    no bgp default ipv4-unicastneighbor 192.168.34.3 remote-as 1address-family ipv4 unicast

    neighbor 192.168.34.3 activatenetwork 4.4.4.4 mask 255.255.255.255

    R3ip vrf MSSKrd 100:1

    route-target export 100:1

    route-target import 100:1

    mpls label protocol ldpmpls ldp router-id Loopback0 force

    interface FastEthernet0/0mpls ip

    router ospf 1

  • 8/10/2019 IOS XR Workbook

    56/232

    55

    router-id 3.3.3.3network 3.3.3.3 0.0.0.0 area 0

    network 192.168.23.3 0.0.0.0 area 0

    router bgp 1

    no bgp default ipv4-unicastbgp log-neighbor-changesneighbor 10.10.10.10 remote-as 1

    neighbor 10.10.10.10 update-source Loopback0

    address-family vpnv4neighbor 10.10.10.10 activateneighbor 10.10.10.10 send-community bothexit-address-family

    address-family ipv4 vrf MSSKneighbor 192.168.34.4 remote-as 2

    neighbor 192.168.34.4 activate

    XR1

    vrf MSSKaddress-family ipv4 unicastimport route-target100:1

    export route-target

    100:1

    interface GigabitEthernet0/0/0/0vrf MSSKipv4 address 192.168.102.10 255.255.255.0

    router ospf 1router-id 10.10.10.10

    area 0interface Loopback0

    interface GigabitEthernet0/0/0/2

    router bgp 1

    address-family vpnv4 unicast

    neighbor 3.3.3.3

    remote-as 1update-source Loopback0address-family vpnv4 unicast

  • 8/10/2019 IOS XR Workbook

    57/232

    56

    vrf MSSKrd 100:1

    address-family ipv4 unicast

    neighbor 192.168.102.1

    remote-as 2address-family ipv4 unicast

    mpls ldprouter-id 10.10.10.10interface GigabitEthernet0/0/0/2

    Verifications

    R1#sh ip bgp summaryBGP router identifier 1.1.1.1, local AS number 2

    BGP table version is 2, main routing table version 21 network entries using 120 bytes of memory1 path entries using 52 bytes of memory2/1 BGP path/bestpath attribute entries using 248 bytes of memory0 BGP route-map cache entries using 0 bytes of memory0 BGP filter-list cache entries using 0 bytes of memoryBitfield cache entries: current 1 (at peak 1) using 32 bytes of memoryBGP using 452 total bytes of memoryBGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd192.168.102.10 4 1 3 5 2 0 0 00:00:31 0

    As can be seen that there are no routes received from XR1 (PE)

    RP/0/0/CPU0:XR1#sh bgp vrf MSSK summaryTue Jun 24 02:52:41.698 UTCBGP VRF MSSK, state: Active

    BGP Route Distinguisher: 100:1VRF ID: 0x60000002BGP router identifier 10.10.10.10, local AS number 1

    BGP table state: Active

    Table ID: 0xe0000002 RD version: 41BGP main routing table version 41

    BGP is operating in STANDALONE mode.

    Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVerSpeaker 41 41 41 41 41 41

    Some configured eBGP neighbors (under default or non-default vrfs)

  • 8/10/2019 IOS XR Workbook

    58/232

    57

    do not have both inbound and outbound policies configured for IPv4 Unicastaddress family. These neighbors will default to sending and/or

    receiving no routes and are marked with '!' in the output below.Use the 'show bgp neighbor ' command for details.

    Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd192.168.102.1 0 2 6 3 41 0 0 00:00:58 0!

    We can see the ! mark which means that no routes will advertised or received from thisneighbor due to the default policy which will drop all prefixes

    RP/0/0/CPU0:XR1#sh bgp vrf MSSK neighbors 192.168.102.1 | include policTue Jun 24 02:53:15.675 UTC

    eBGP neighbor with no inbound or outbound policy; defaults to 'drop'

    No policy: 1, Failed RT match: 0By ORF policy: 0, By policy: 0

    So , we have to define a route-policy that will allow the routes exchange

    XR1

    route-policy PASSpass

    router bgp 1vrf MSSKneighbor 192.168.102.1

    address-family ipv4 unicastroute-policy PASS inroute-policy PASS out

    RP/0/0/CPU0:XR1#sh bgp vrf MSSK summary

    Tue Jun 24 02:54:28.420 UTCBGP VRF MSSK, state: ActiveBGP Route Distinguisher: 100:1

    VRF ID: 0x60000002BGP router identifier 10.10.10.10, local AS number 1BGP table state: Active

    Table ID: 0xe0000002 RD version: 42

    BGP main routing table version 42

    BGP is operating in STANDALONE mode.

    Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer

    Speaker 42 42 42 42 42 42

    Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd192.168.102.1 0 2 10 6 42 0 0 00:02:45 1

  • 8/10/2019 IOS XR Workbook

    59/232

    58

    R1#sh ip bgp summary

    BGP router identifier 1.1.1.1, local AS number 2BGP table version is 2, main routing table version 21 network entries using 120 bytes of memory

    1 path entries using 52 bytes of memory2/1 BGP path/bestpath attribute entries using 248 bytes of memory0 BGP route-map cache entries using 0 bytes of memory

    0 BGP filter-list cache entries using 0 bytes of memoryBitfield cache entries: current 1 (at peak 1) using 32 bytes of memoryBGP using 452 total bytes of memoryBGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

    192.168.102.10 4 1 6 10 2 0 0 00:04:52 0

    Still we do not receive any routes , what new about IOS XR is that we need to add a

    /32 route for the labled next-hop address

    XR1

    router staticvrf MSSKaddress-family ipv4 unicast192.168.102.1/32 GigabitEthernet0/0/0/0

    And still there are no routes , let us turn some debugging on R4 and softly clear the

    session

    R4#debug ip bgp updatesBGP updates debugging is on for address family: IPv4 UnicastR4#clear ip bgp * soft in

    R4#*Mar 3 21:13:29.218: BGP(0): 192.168.34.3 rcv UPDATE w/ attr: nexthop192.168.34.3, origin i, originator 0.0.0.0, path 1 2, community , extended community

    *Mar 3 21:13:29.226: BGP(0): 192.168.34.3 rcv UPDATE about 1.1.1.1/32 -- DENIEDdue to: AS-PATH contains our own AS;

    So , R4 will not install any updates originated from R1 because its originated from the

    same AS R4 resides in

    R3router bgp 1address-family ipv4 vrf MSSK

    neighbor 192.168.34.4 as-override

    *Mar 3 21:15:15.974: BGP(0): 192.168.34.3 send UPDATE (format) 4.4.4.4/32, next192.168.34.4, metric 0, path Local

  • 8/10/2019 IOS XR Workbook

    60/232

  • 8/10/2019 IOS XR Workbook

    61/232

    60

    Note that we cannot reach using the physical links between our CEs and PEs becausewe did not advertise them into BGP

    R4#sh ip bgpBGP table version is 7, local router ID is 4.4.4.4

    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,r RIB-failure, S Stale

    Origin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path*> 1.1.1.1/32 192.168.34.3 0 1 1 i*> 4.4.4.4/32 0.0.0.0 0 32768 i

    R4#ping 1.1.1.1 source lo0

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

    Packet sent with a source address of 4.4.4.4!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 576/688/784 ms

    R1#ping 4.4.4.4

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:.....

    Success rate is 0 percent (0/5)

    R3router bgp 1address-family ipv4 vrf MSSK

    network 192.168.34.0 mask 255.255.255.0

    XR1

    router bgp 1vrf MSSKaddress-family ipv4 unicast

    network 192.168.102.0/24

    R1#ping 4.4.4.4

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

    !!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 568/684/772 ms

  • 8/10/2019 IOS XR Workbook

    62/232

    61

    MPLS Tunneling

    Network Diagram

    XR1

    R2

    R3

    192.168.102.0/24

    192.168.101.0/24 192.168.23.0/24

    192.168.34.0/24

    OSPF A0

    AS1

    Lo0 1.1.1.1/32

    Lo0 3.3.3.3/32

    Lo0 4.4.4.4/32

    10.10.10.10/32

    Lo0 2.2.2.2/32

    BGP

    R1

    BGP

    R4

    S10 AS40

    Initial Configurations

    R1

    interface Loopback0ip address 1.1.1.1 255.255.255.255

    interface FastEthernet0/0ip address 192.168.102.1 255.255.255.0

    duplex autospeed autono shutdown

    R2

    interface Loopback0ip address 2.2.2.2 255.255.255.255

    interface FastEthernet0/0

    ip address 192.168.101.2 255.255.255.0duplex autospeed autompls ipno shutdown

  • 8/10/2019 IOS XR Workbook

    63/232

    62

    interface FastEthernet0/1

    ip address 192.168.23.2 255.255.255.0speed 100full-duplex

    mpls ipno shutdown

    R3interface Loopback0ip address 3.3.3.3 255.255.255.255

    interface FastEthernet0/0ip address 192.168.23.3 255.255.255.0

    speed 100full-duplexmpls ip

    no shutdown

    interface FastEthernet0/1

    ip address 192.168.34.3 255.255.255.0speed 100full-duplexno shutdown

    R4

    interface Loopback0ip address 4.4.4.4 255.255.255.255

    interface FastEthernet0/0ip address 192.168.34.4 255.255.255.0

    speed 100full-duplexno shutdown

    XR1interface Loopback0

    ipv4 address 10.10.10.10 255.255.255.0

    interface GigabitEthernet0/0/0/0

    cdpipv4 address 192.168.102.10 255.255.255.0duplex full

    no shutdown

    interface GigabitEthernet0/0/0/2cdp

  • 8/10/2019 IOS XR Workbook

    64/232

    63

    ipv4 address 192.168.101.10 255.255.255.0no shutdown

  • 8/10/2019 IOS XR Workbook

    65/232

    64

    Configurations

    R1router bgp 10no bgp default ipv4-unicastbgp log-neighbor-changesneighbor 192.168.102.10 remote-as 1

    address-family ipv4neighbor 192.168.102.10 activate

    no auto-summaryno synchronizationnetwork 1.1.1.1 mask 255.255.255.255

    exit-address-family

    R4

    router bgp 40no bgp default ipv4-unicastbgp log-neighbor-changesneighbor 192.168.34.3 remote-as 1

    address-family ipv4neighbor 192.168.34.3 activateno auto-summaryno synchronization

    network 4.4.4.4 mask 255.255.255.255

    exit-address-family

    R3router bgp 1no bgp default ipv4-unicast

    bgp log-neighbor-changesneighbor 10.10.10.10 remote-as 1neighbor 10.10.10.10 update-source Loopback0

    neighbor 192.168.34.4 remote-as 40

    address-family ipv4

    neighbor 10.10.10.10 activate

    neighbor 10.10.10.10 next-hop-selfneighbor 192.168.34.4 activateno auto-summaryno synchronization

    exit-address-family

    address-family vpnv4

    neighbor 10.10.10.10 activateneighbor 10.10.10.10 send-community both

  • 8/10/2019 IOS XR Workbook

    66/232

  • 8/10/2019 IOS XR Workbook

    67/232

    66

    FastEthernet0/1, Src IP addr: 192.168.23.3Addresses bound to peer LDP Ident:

    192.168.23.3 3.3.3.3 192.168.34.3

    R3#sh mpls interfaces

    Interface IP Tunnel OperationalFastEthernet0/0 Yes (ldp) No Yes

    R3#sh mpls ldp neighborPeer LDP Ident: 2.2.2.2:0; Local LDP Ident 3.3.3.3:0

    TCP connection: 2.2.2.2.646 - 3.3.3.3.12506State: Oper; Msgs sent/rcvd: 266/261; DownstreamUp time: 03:42:03LDP discovery sources:

    FastEthernet0/0, Src IP addr: 192.168.23.2Addresses bound to peer LDP Ident:192.168.101.2 192.168.23.2 2.2.2.2

    RP/0/0/CPU0:XR1#show mpls interfacesSun Apr 27 15:57:58.622 UTC

    Interface LDP Tunnel Static Enabled-------------------------- -------- -------- -------- --------GigabitEthernet0/0/0/2 Yes No No Yes

    RP/0/0/CPU0:XR1#show mpls ldp neighborSun Apr 27 15:58:00.832 UTC

    Peer LDP Identifier: 2.2.2.2:0TCP connection: 2.2.2.2:646 - 10.10.10.10:20151Graceful Restart: NoSession Holdtime: 180 sec

    State: Oper; Msgs sent/rcvd: 276/284; Downstream-UnsolicitedUp time: 03:53:32LDP Discovery Sources:

    GigabitEthernet0/0/0/2Addresses bound to this peer:

    2.2.2.2 192.168.23.2 192.168.101.2

    R1#sh ip bgp summaryBGP router identifier 1.1.1.1, local AS number 10

    BGP table version is 5, main routing table version 52 network entries using 240 bytes of memory2 path entries using 104 bytes of memory

    3/2 BGP path/bestpath attribute entries using 372 bytes of memory1 BGP AS-PATH entries using 24 bytes of memory0 BGP route-map cache entries using 0 bytes of memory0 BGP filter-list cache entries using 0 bytes of memory

  • 8/10/2019 IOS XR Workbook

    68/232

    67

    Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memoryBGP using 772 total bytes of memory

    BGP activity 2/0 prefixes, 3/1 paths, scan interval 60 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

    192.168.102.10 4 1 16 17 5 0 0 00:12:05 1R1#sh ip bgpBGP table version is 5, local router ID is 1.1.1.1

    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,r RIB-failure, S Stale

    Origin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path*> 1.1.1.1/32 0.0.0.0 0 32768 i

    *> 4.4.4.4/32 192.168.102.10 0 1 40 i

    R4#sh ip bgp summary

    BGP router identifier 4.4.4.4, local AS number 40BGP table version is 5, main routing table version 52 network entries using 240 bytes of memory

    2 path entries using 104 bytes of memory3/2 BGP path/bestpath attribute entries using 372 bytes of memory1 BGP AS-PATH entries using 24 bytes of memory0 BGP route-map cache entries using 0 bytes of memory0 BGP filter-list cache entries using 0 bytes of memoryBitfield cache entries: current 1 (at peak 1) using 32 bytes of memory

    BGP using 772 total bytes of memoryBGP activity 3/1 prefixes, 3/1 paths, scan interval 60 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd192.168.34.3 4 1 20 18 5 0 0 00:13:17 1

    R4#sh ip bgpBGP table version is 5, local router ID is 4.4.4.4Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

    r RIB-failure, S StaleOrigin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path

    *> 1.1.1.1/32 192.168.34.3 0 1 10 i*> 4.4.4.4/32 0.0.0.0 0 32768 i

    R3#sh ip bgp summary

    BGP router identifier 3.3.3.3, local AS number 1BGP table version is 5, main routing table version 52 network entries using 240 bytes of memory2 path entries using 104 bytes of memory

  • 8/10/2019 IOS XR Workbook

    69/232

    68

    3/2 BGP path/bestpath attribute entries using 372 bytes of memory2 BGP AS-PATH entries using 48 bytes of memory

    0 BGP route-map cache entries using 0 bytes of memory0 BGP filter-list cache entries using 0 bytes of memoryBitfield cache entries: current 2 (at peak 3) using 64 bytes of memory

    BGP using 828 total bytes of memoryBGP activity 15/13 prefixes, 42/40 paths, scan interval 60 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd10.10.10.10 4 1 271 284 5 0 0 00:02:58 1192.168.34.4 4 40 18 20 5 0 0 00:13:33 1R3#sh ip bgpBGP table version is 5, local router ID is 3.3.3.3Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

    r RIB-failure, S StaleOrigin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path*>i1.1.1.1/32 10.10.10.10 0 100 0 10 i*> 4.4.4.4/32 192.168.34.4 0 0 40 i

    RP/0/0/CPU0:XR1#sh bgp ipv4 unicast summarySun Apr 27 15:59:06.457 UTCBGP router identifier 10.10.10.10, local AS number 1BGP generic scan interval 60 secsBGP table state: Active

    Table ID: 0xe0000000 RD version: 5BGP main routing table version 5BGP scan interval 60 secs

    BGP is operating in STANDALONE mode.

    Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVerSpeaker 5 5 5 5 5 5

    Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd3.3.3.3 0 1 284 272 5 0 0 00:03:09 1

    192.168.102.1 0 10 17 17 5 0 0 00:12:25 1

    RP/0/0/CPU0:XR1#sh bgp ipv4 unicast

    Sun Apr 27 15:59:07.957 UTCBGP router identifier 10.10.10.10, local AS number 1BGP generic scan interval 60 secs

    BGP table state: ActiveTable ID: 0xe0000000 RD version: 5BGP main routing table version 5BGP scan interval 60 secs

  • 8/10/2019 IOS XR Workbook

    70/232

    69

    Status codes: s suppressed, d damped, h history, * valid, > best

    i - internal, r RIB-failure, S stale, N Nexthop-discardOrigin codes: i - IGP, e - EGP, ? - incompleteNetwork Next Hop Metric LocPrf Weight Path

    *> 1.1.1.1/32 192.168.102.1 0 0 10 i*>i4.4.4.4/32 3.3.3.3 0 100 0 40 i

    Processed 2 prefixes, 2 paths

    R3#show mpls forwarding-tableLocal Outgoing Prefix Bytes tag Outgoing Next Hoptag tag or VC or Tunnel Id switched interface16 Pop tag 2.2.2.2/32 0 Fa0/0 192.168.23.2

    17 16 10.10.10.10/32 0 Fa0/0 192.168.23.218 Pop tag 192.168.101.0/24 0 Fa0/0 192.168.23.2

    RP/0/0/CPU0:XR1#show mpls forwardingSun Apr 27 15:59:41.095 UTC

    Local Outgoing Prefix Outgoing Next Hop BytesLabel Label or ID Interface Switched------ ----------- ------------------ ------------ --------------- ------------16001 Pop 2.2.2.2/32 Gi0/0/0/2 192.168.101.2 1279716002 Pop 192.168.23.0/24 Gi0/0/0/2 192.168.101.2 016003 17 3.3.3.3/32 Gi0/0/0/2 192.168.101.2 20720

    R1#ping 4.4.4.4 source lo0

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

    Packet sent with a source address of 1.1.1.1!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 172/186/192 ms

    R1#traceroute 4.4.4.4 source lo0

    Type escape sequence to abort.

    Tracing the route to 4.4.4.4

    1 192.168.102.10 32 msec 28 msec 28 msec2 192.168.101.2 [MPLS: Label 17 Exp 0] 160 msec 96 msec 188 msec3 192.168.23.3 128 msec 132 msec 132 msec

    4 192.168.34.4 196 msec 180 msec 176 msec

    R4#ping 1.1.1.1 source lo0

  • 8/10/2019 IOS XR Workbook

    71/232

    70

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

    Packet sent with a source address of 4.4.4.4!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 164/190/220 ms

    R4#traceroute 1.1.1.1 source lo0

    Type escape sequence to abort.Tracing the route to 1.1.1.1

    1 192.168.34.3 64 msec 64 msec 44 msec2 192.168.23.2 [MPLS: Label 16 Exp 0] 164 msec 156 msec 160 msec3 192.168.101.10 160 msec 160 msec 160 msec

    4 192.168.102.1 188 msec 192 msec 192 msec

  • 8/10/2019 IOS XR Workbook

    72/232

    71

    Carrier Supporting Carrier (CsC) 1

    Network Diagram

    XR1

    R2

    R3

    192.

    16

    8.

    102.

    0/24

    192.168.101.0/24 192.168.23.0/24

    192.

    168.

    34.

    0/24

    R1

    192.

    168.

    15.

    0/24

    R5

    192.

    168.46.

    0/24

    R4

    R6

    AS 1

    AS 14

    AS 14

    Initial Configurations

    R1interface FastEthernet1/0

    ip address 192.168.102.1 255.255.255.0speed autoduplex autono shutdown

    interface FastEthernet1/1ip address 192.168.15.1 255.255.255.0speed 100duplex fullno shutdown

    interface Loopback0

    ip address 1.1.1.1 255.255.255.255

  • 8/10/2019 IOS XR Workbook

    73/232

    72

    R2interface FastEthernet1/0

    ip address 192.168.101.2 255.255.255.0speed autoduplex auto

    no shutdown

    interface FastEthernet1/1

    ip address 192.168.23.2 255.255.255.0speed 100duplex fullno shutdown

    interface Loopback0

    ip address 2.2.2.2 255.255.255.255

    R3

    interface FastEthernet1/0ip address 192.168.23.3 255.255.255.0speed 100

    duplex fullno shutdown

    interface FastEthernet1/1ip address 192.168.34.3 255.255.255.0speed 100

    duplex fullno shutdown

    interface Loopback0ip address 3.3.3.3 255.255.255.255

    R4interface FastEthernet1/0

    ip address 192.168.34.4 255.255.255.0speed 100duplex full

    no shutdown

    interface FastEthernet1/1

    ip address 192.168.46.4 255.255.255.0speed 100duplex full

    no shutdown

    interface Loopback0ip address 4.4.4.4 255.255.255.255

  • 8/10/2019 IOS XR Workbook

    74/232

    73

    R5interface FastEthernet1/0

    ip address 192.168.15.5 255.255.255.0duplex fullspeed 100

    no shutdown

    interface Loopback0

    ip address 5.5.5.5 255.255.255.255

    R6interface FastEthernet1/0ip address 192.168.46.6 255.255.255.0speed 100

    duplex fullno shutdown

    interface Loopback0ip address 6.6.6.6 255.255.255.255

    RP/0/0/CPU0:XR1hostname XR1cdp

    interface Loopback0ipv4 address 10.10.10.10 255.255.255.255

    interface GigabitEthernet0/0/0/0cdpipv4 address 192.168.102.10 255.255.255.0duplex full

    interface GigabitEthernet0/0/0/2cdp

    ipv4 address 192.168.101.10 255.255.255.0

  • 8/10/2019 IOS XR Workbook

    75/232

    74

    Configurations

    R1interface FastEthernet1/0ip address 192.168.102.1 255.255.255.0speed autoduplex auto

    mpls bgp forwarding

    interface FastEthernet1/1

    vrf forwarding ABCip address 192.168.15.1 255.255.255.0speed 100

    duplex full

    interface Loopback0

    ip address 1.1.1.1 255.255.255.255

    vrf definition ABCrd 200:1

    address-family ipv4route-target export 200:1route-target import 200:1exit-address-family

    router ospf 56 vrf ABCrouter-id 1.1.1.1

    redistribute bgp 14 subnetsnetwork 192.168.15.1 0.0.0.0 area 0

    router bgp 14bgp log-neighbor-changesno bgp default ipv4-unicast

    neighbor 4.4.4.4 remote-as 14neighbor 4.4.4.4 update-source Loopback0neighbor 192.168.102.10 remote-as 1

    address-family ipv4network 1.1.1.1 mask 255.255.255.255neighbor 192.168.102.10 activateneighbor 192.168.102.10 send-label

    exit-address-familyaddress-family vpnv4

    neighbor 4.4.4.4 activate

    neighbor 4.4.4.4 send-community extendedexit-address-family

  • 8/10/2019 IOS XR Workbook

    76/232

    75

    address-family ipv4 vrf ABC

    redistribute ospf 56exit-address-family

    R2interface FastEthernet1/0ip address 192.168.101.2 255.255.255.0

    ip ospf network point-to-pointspeed autoduplex autompls ip

    interface FastEthernet1/1

    ip address 192.168.23.2 255.255.255.0ip ospf network point-to-pointspeed 100

    duplex fullmpls ip

    interface Loopback0ip address 2.2.2.2 255.255.255.255

    router ospf 1router-id 2.2.2.2network 2.2.2.2 0.0.0.0 area 0

    network 192.168.23.2 0.0.0.0 area 0network 192.168.101.2 0.0.0.0 area 0

    mpls label protocol ldpmpls ldp router-id Loopback0 force

    R3interface FastEthernet1/0

    ip address 192.168.23.3 255.255.255.0ip ospf network point-to-pointspeed 100

    duplex full

    mpls ip

    interface FastEthernet1/1vrf forwarding MSSKip address 192.168.34.3 255.255.255.0

    speed 100duplex fullmpls bgp forwarding

  • 8/10/2019 IOS XR Workbook

    77/232

    76

    interface Loopback0ip address 3.3.3.3 255.255.255.255

    router ospf 1router-id 3.3.3.3

    network 3.3.3.3 0.0.0.0 area 0network 192.168.23.3 0.0.0.0 area 0

    router bgp 1bgp log-neighbor-changesno bgp default ipv4-unicastneighbor 10.10.10.10 remote-as 1neighbor 10.10.10.10 update-source Loopback0

    address-family ipv4exit-address-family

    address-family vpnv4neighbor 10.10.10.10 activateneighbor 10.10.10.10 send-community both

    exit-address-family

    address-family ipv4 vrf MSSKneighbor 192.168.34.4 remote-as 14neighbor 192.168.34.4 activateneighbor 192.168.34.4 as-override

    neighbor 192.168.34.4 send-labelexit-address-family

    mpls label protocol ldpmpls ldp router-id Loopback0 force

    R4interface FastEthernet1/0

    ip address 192.168.34.4 255.255.255.0speed 100duplex full

    mpls bgp forwarding

    interface FastEthernet1/1

    vrf forwarding ABCip address 192.168.46.4 255.255.255.0speed 100

    duplex full

    interface Loopback0ip address 4.4.4.4 255.255.255.255

  • 8/10/2019 IOS XR Workbook

    78/232

    77

    vrf definition ABC

    rd 200:1

    address-family ipv4

    route-target export 200:1route-target import 200:1exit-address-family

    router ospf 56 vrf ABCrouter-id 4.4.4.4redistribute bgp 14 subnetsnetwork 192.168.46.4 0.0.0.0 area 0

    router bgp 14bgp log-neighbor-changesno bgp default ipv4-unicast

    neighbor 1.1.1.1 remote-as 14neighbor 1.1.1.1 update-source Loopback0neighbor 192.168.34.3 remote-as 1

    address-family ipv4network 4.4.4.4 mask 255.255.255.255neighbor 192.168.34.3 activateneighbor 192.168.34.3 send-labelexit-address-family

    address-family vpnv4neighbor 1.1.1.1 activateneighbor 1.1.1.1 send-community extendedexit-address-family

    address-family ipv4 vrf ABCredistribute ospf 56

    exit-address-family

    R5

    interface FastEthernet1/0

    ip address 192.168.15.5 255.255.255.0duplex full

    interface Loopback0ip address 5.5.5.5 255.255.255.255

    router ospf 56router-id 5.5.5.5network 5.5.5.5 0.0.0.0 area 0

  • 8/10/2019 IOS XR Workbook

    79/232

    78

    network 192.168.15.5 0.0.0.0 area 0

    R6interface FastEthernet1/0ip address 192.168.46.6 255.255.255.0

    speed 100duplex full

    interface Loopback0ip address 6.6.6.6 255.255.255.255

    router ospf 56router-id 6.6.6.6network 6.6.6.6 0.0.0.0 area 0

    network 192.168.46.6 0.0.0.0 area 0

    RP/0/0/CPU0:XR1

    hostname XR1cdpvrf MSSK

    address-family ipv4 unicastimport route-target100:1

    export route-target100:1

    address-family ipv6 unicastimport route-target100:1

    export route-target100:1

    interface Loopback0ipv4 address 10.10.10.10 255.255.255.255ipv6 address 2001::10/128

    interface GigabitEthernet0/0/0/0cdp

    vrf MSSKipv4 address 192.168.102.10 255.255.255.0duplex full

    interface GigabitEthernet0/0/0/2cdpipv4 address 192.168.101.10 255.255.255.0

  • 8/10/2019 IOS XR Workbook

    80/232

    79

    route-policy PASS_CE

    passend-policy

    router staticvrf MSSKaddress-family ipv4 unicast

    192.168.102.1/32 GigabitEthernet0/0/0/0

    router ospf 1router-id 10.10.10.10area 0interface Loopback0

    interface GigabitEthernet0/0/0/2network point-to-point

    router ospfv3 1router-id 10.10.10.10

    area 0interface Loopback0

    interface GigabitEthernet0/0/0/2network point-to-point

    router bgp 1address-family ipv4 unicast

    address-family vpnv4 unicast

    neighbor 3.3.3.3remote-as 1update-source Loopback0

    address-family vpnv4 unicast

    vrf MSSK

    rd 100:1

    address-family ipv4 unicastallocate-label all

    neighbor 192.168.102.1remote-as 14

    address-family ipv4 labeled-unicastroute-policy PASS_CE inroute-policy PASS_CE outas-override

  • 8/10/2019 IOS XR Workbook

    81/232

    80

    mpls ldp

    router-id 10.10.10.10interface GigabitEthernet0/0/0/2

    Verifications

    R1#sh ip bgp summary

    BGP router identifier 1.1.1.1, local AS number 14BGP table version is 3, main routing table version 32 network entries using 288 bytes of memory2 path entries using 160 bytes of memory2/2 BGP path/bestpath attribute entries using 272 bytes of memory1 BGP AS-PATH entries using 24 bytes of memory

    2 BGP extended community entries using 80 bytes of memory0 BGP route-map cache entries using 0 bytes of memory0 BGP filter-list cache entries using 0 bytes of memory

    BGP using 824 total bytes of memoryBGP activity 26/20 prefixes, 33/27 paths, scan interval 60 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/DownState/PfxRcd192.168.102.10 4 1 49 56 3 0 0 00:47:49 1

    R1#sh ip bgpBGP table version is 3, local router ID is 1.1.1.1

    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,x best-external, a additional-path, c RIB-compressed,

    Origin codes: i - IGP, e - EGP, ? - incompleteRPKI validation codes: V valid, I invalid, N Not found

    Network Next Hop Metric LocPrf Weight Path*> 1.1.1.1/32 0.0.0.0 0 32768 i

    *> 4.4.4.4/32 192.168.102.10 0 1 1 i

    R1#ping 4.4.4.4 source lo0

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:Packet sent with a source address of 1.1.1.1

    !!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 288/465/628 ms

    R1#traceroute 4.4.4.4 source lo0Type escape sequence to abort.Tracing the route to 4.4.4.4VRF info: (vrf in name/id, vrf out name/id)

  • 8/10/2019 IOS XR Workbook

    82/232

    81

    1 192.168.102.10 [MPLS: Label 16005 Exp 0] 484 msec 364 msec 520 msec2 192.168.101.2 [MPLS: Labels 17/21 Exp 0] 388 msec 360 msec 468 msec

    3 192.168.34.3 [MPLS: Label 21 Exp 0] 280 msec 280 msec 308 msec4 192.168.34.4 472 msec 560 msec 564 msec

    R1#sh bgp vpnv4 unicast all summaryBGP router identifier 1.1.1.1, local AS number 14BGP table version is 7, main routing table version 7

    4 network entries using 624 bytes of memory4 path entries using 320 bytes of memory4/4 BGP path/bestpath attribute entries using 576 bytes of memory1 BGP AS-PATH entries using 24 bytes of memory2 BGP extended community entries using 80 bytes of memory0 BGP route-map cache entries using 0 bytes of memory

    0 BGP filter-list cache entries using 0 bytes of memoryBGP using 1624 total bytes of memoryBGP activity 26/20 prefixes, 33/27 paths, scan interval 60 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/DownState/PfxRcd

    4.4.4.4 4 14 58 59 7 0 0 00:49:07 2

    R1#sh bgp vpnv4 unicast allBGP table version is 7, local router ID is 1.1.1.1Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

    r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

    x best-external, a additional-path, c RIB-compressed,Origin codes: i - IGP, e - EGP, ? - incompleteRPKI validation codes: V valid, I invalid, N Not found

    Network Next Hop Metric LocPrf Weight Path

    Route Distinguisher: 200:1 (default for vrf ABC)*> 5.5.5.5/32 192.168.15.5 2 32768 ?*>i 6.6.6.6/32 4.4.4.4 2 100 0 ?

    *> 192.168.15.0 0.0.0.0 0 32768 ?*>i 192.168.46.0 4.4.4.4 0 100 0 ?

    R1#sh bgp vpnv4 unicast all neighbors 4.4.4.4 advertised-routes

    BGP table version is 7, local router ID is 1.1.1.1Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

    r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,x best-external, a additional-path, c RIB-compressed,

    Origin codes: i - IGP, e - EGP, ? - incomplete

    RPKI validation codes: V valid, I invalid, N Not found

    Network Next Hop Metric LocPrf Weight PathRoute Distinguisher: 200:1 (default for vrf ABC)

  • 8/10/2019 IOS XR Workbook

    83/232

    82

    *> 5.5.5.5/32 192.168.15.5 2 32768 ?*> 192.168.15.0 0.0.0.0 0 32768 ?

    Total number of prefixes 2

    R1#sh mpls interfacesInterface IP Tunnel BGP Static OperationalFastEthernet1/0 No No Yes No Yes

    R4#sh ip bgp summaryBGP router identifier 4.4.4.4, local AS number 14BGP table version is 3, main routing table version 32 network entries using 288 bytes of memory2 path entries using 160 bytes of memory

    2/2 BGP path/bestpath attribute entries using 272 bytes of memory1 BGP AS-PATH entries using 24 bytes of memory2 BGP extended community entries using 80 bytes of memory

    0 BGP route-map cache entries using 0 bytes of memory0 BGP filter-list cache entries using 0 bytes of memoryBGP using 824 total bytes of memory

    BGP activity 25/19 prefixes, 32/26 paths, scan interval 60 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/DownState/PfxRcd192.168.34.3 4 1 59 60 3 0 0 00:50:31 1

    R4#sh ip bgpBGP table version is 3, local router ID is 4.4.4.4Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

    r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,x best-external, a additional-path, c RIB-compressed,

    Origin codes: i - IGP, e - EGP, ? - incompleteRPKI validation codes: V valid, I invalid, N Not found

    Network Next Hop Metric LocPrf Weight Path*> 1.1.1.1/32 192.168.34.3 0 1 1 i*> 4.4.4.4/32 0.0.0.0 0 32768 i

    R4#ping 1.1.1.1 source lo0Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:Packet sent with a source address of 4.4.4.4!!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 360/440/508 ms

    R4#traceroute 1.1.1.1 source lo0Type escape sequence to abort.

  • 8/10/2019 IOS XR Workbook

    84/232

    83

    Tracing the route to 1.1.1.1VRF info: (vrf in name/id, vrf out name/id)

    1 192.168.34.3 [MPLS: Label 23 Exp 0] 408 msec 376 msec 440 msec2 192.168.23.2 [MPLS: Labels 16/16004 Exp 0] 468 msec 528 msec 520 msec3 192.168.101.10 [MPLS: Label 16004 Exp 0] 444 msec 536 msec 444 msec

    4 192.168.102.1 536 msec 360 msec 384 msec

    R4#sh bgp vpnv4 unicast all summary

    BGP router identifier 4.4.4.4, local AS number 14BGP table version is 7, main routing table version 74 network entries using 624 bytes of memory4 path entries using 320 bytes of memory4/4 BGP path/bestpath attribute entries using 576 bytes of memory1 BGP AS-PATH entries using 24 bytes of memory

    2 BGP extended community entries using 80 bytes of memory0 BGP route-map cache entries using 0 bytes of memory0 BGP filter-list cache entries using 0 bytes of memory

    BGP using 1624 total bytes of memoryBGP activity 25/19 prefixes, 32/26 paths, scan interval 60 secs

    Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/DownState/PfxRcd1.1.1.1 4 14 61 61 7 0 0 00:51:18 2

    R4#sh bgp vpnv4 unicast allBGP table version is 7, local router ID is 4.4.4.4

    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,x best-external, a additional-path, c RIB-compressed,

    Origin codes: i - IGP, e - EGP, ? - incompleteRPKI validation codes: V valid, I invalid, N Not found

    Network Next Hop Metric LocPrf Weight PathRoute Distinguisher: 200:1 (default for vrf ABC)

    *>i 5.5.5.5/32 1.1.1.1 2 100 0 ?*> 6.6.6.6/32 192.168.46.6 2 32768 ?*>i 192.168.15.0 1.1.1.1 0 100 0 ?

    *> 192.168.46.0 0.0.0.0 0 32768 ?

    R4#sh bgp vpnv4 unicast all neighbors 1.1.1.1 advertised-routes

    BGP table version is 7, local router ID is 4.4.4.4Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

    r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

    x best-external, a additional-path, c RIB-compressed,Origin codes: i - IGP, e - EGP, ? - incompleteRPKI validation codes: V valid, I invalid, N Not found

  • 8/10/2019 IOS XR Workbook

    85/232

    84

    Network Next Hop Metric LocPrf Weight PathRoute Distinguisher: 200:1 (default for vrf ABC)

    *> 6.6.6.6/32 192.168.46.6 2 32768 ?*> 192.168.46.0 0.0.0.0 0 32768 ?

    Total number of prefixes 2

    R4#sh mpls interfaces

    Interface IP Tunnel BGP Static OperationalFastEthernet1/0 No No Yes No Yes