9304m Command Line 9308m Interface Reference...

868
9304m Command Line 9308m Interface Reference 9315m 9408sl ProCurve Routing Switches Software versions 07.8.00a (9300 series) and 01.0.02 (9408sl) www.procurve.com

Transcript of 9304m Command Line 9308m Interface Reference...

  • 9304m Command Line 9308m Interface Reference 9315m 9408sl

    ProCurve Routing Switches Software versions 07.8.00a (9300 series) and 01.0.02 (9408sl)

    www.procurve.com

  • Command Line Interface Reference

    for ProCurve 9300/9400 Series

    Routing Switches

    Software versions 07.8.00a (9300 Series) and 01.0.02 (9408sl)

  • Copyright 2002, 2005

    Hewlett-Packard Company

    All rights reserved. Reproduction, adaptation or translation without prior written permission is prohibited, except as allowed under the copyright laws.

    Publication number

    5990-6031

    June 2005

    Applicable Products

    ProCurve 9304M (J4139A) ProCurve 9308M (J4138A) ProCurve 9315M (J4874A) ProCurve 9408sl (J8680A)

    Trademark Credits

    Microsoft, Windows, Microsoft Windows NT and

    Internet Explorer are U.S. trademarks of Microsoft

    Corporation. Netscape Navigator is a U.S. trademark of Netscape Communications

    Corporation. Cisco is a trademark of Cisco Systems Inc.

    Disclaimer

    The information contained in this document is subject to change without notice.

    HEWLETT-PACKARD COMPANY MAKES NO WARRANTY OF ANY KIND WITH REGARD TO THIS MATERIAL, INCLUDING BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

    Hewlett-Packard shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance or use of this material.

    Hewlett-Packard assumes no responsibility for the use or reliability of its software on equipment that is not furnished by Hewlett-Packard.

    A copy of the specific warranty terms applicable to your HP product and replacement parts can be obtained from your HP Sales and Service Office or authorized dealer.

    Warranty

    See the Customer Support and Warranty booklet included with the product.

    A copy of the specific warranty terms applicable to your Hewlett-Packard products and replacement parts can be obtained from your HP Sales and Service Office or authorized dealer.

    Safety Considerations

    Prior to the installation and use of this product, review all safety markings and instructions.

    Instruction Manual Symbol.

    If the product is marked with the above symbol, refer to the product manual to protect the product from damage.

    WARNING Denotes a hazard that can cause injury.

    CAUTION Denotes a hazard that can damage equipment or data.

    Do not proceed beyond a WARNING or CAUTION notice until you have understood the hazard and have taken appropriate precautions.

    Use of control, adjustments or performance procedures other than those specified herein may result in hazardous radiation exposure.

    Grounding

    This product provides a protective earthing terminal. There must be an uninterrupted safety earth ground from the main power source to the products input wiring terminals, power cord or supplied power cord set. Whenever it is likely that the protection has been impaired, disconnect the power cord until the ground has been restored.

    If your LAN covers an area served by more than one power distribution system, be sure their safety grounds are securely interconnected.

    LAN cables may occasionally be subject to hazardous transient voltages (such as lightning or disturbances in the electrical utilities power grid). Handle exposed metal components of the network with caution.

    Servicing

    There are no user-serviceable parts inside the userinstallable modules comprising the product. Any servicing, adjustment, maintenance or repair must be performed only by service-trained personnel.

    ii

  • Contents

    Organization of Product Documentation ................................................ xi

    Chapter 1Getting Started ........................................................................................ 1-1

    Introduction ...............................................................................................................................................1-1

    Software Versions Covered ......................................................................................................................1-1

    Audience ...................................................................................................................................................1-1

    Conventions ..............................................................................................................................................1-2

    Terminology ..............................................................................................................................................1-2

    Support and Warranty Information ...........................................................................................................1-2

    Related Publications .................................................................................................................................1-2

    Chapter 2Using the Command Line Interface....................................................... 2-1

    EXEC Commands ....................................................................................................................................2-2

    Privileged Level ..................................................................................................................................2-2

    CONFIG Commands ................................................................................................................................2-2

    Global Level .......................................................................................................................................2-2

    Redundancy Level .............................................................................................................................2-3

    Interface Level ....................................................................................................................................2-3

    Trunk Level ........................................................................................................................................2-3

    IPV6 Access List Level .......................................................................................................................2-3

    Router RIP Level ................................................................................................................................2-3

    IPv6 RIP Level(HP devices that support IPv6 only) ...........................................................................2-3

    Router OSPF Level ............................................................................................................................2-3

    OSPF Version 3 Level (HP devices that support IPv6 only) ..............................................................2-3

    BGP Level ..........................................................................................................................................2-3

    Global BGP and BGP4 Unicast Address Family Level ......................................................................2-3

    BGP4 Multicast Address Family Level (HP devices that support IPv6 only) ......................................2-4

    IPv6 BGP Unicast Address Family Level (HP devices that support IPv6 only) ..................................2-4

    June 2005 iii

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    IP Tunnel Level ..................................................................................................................................2-4

    Router MSDP Level ...........................................................................................................................2-4

    Router DVMRP Level .........................................................................................................................2-4

    Router PIM Level ...............................................................................................................................2-4

    IPv6 Router PIM Level (HP devices that support IPv6 only) ..............................................................2-4

    Broadcast Filter Level ........................................................................................................................2-4

    Multicast Filter Level ..........................................................................................................................2-4

    Route Map Level ................................................................................................................................2-4

    Router VRRP Level ............................................................................................................................2-4

    Router VRRPE Level .........................................................................................................................2-5

    VLAN Level ........................................................................................................................................2-5

    Metro Ring Level ................................................................................................................................2-5

    VSRP Level ........................................................................................................................................2-5

    Topology Group Level ........................................................................................................................2-5

    STP Group Level ................................................................................................................................2-5

    GVRP Level .......................................................................................................................................2-5

    Real Server Level ..............................................................................................................................2-5

    Application Port Level .......................................................................................................................2-5

    Accessing the CLI .....................................................................................................................................2-6

    Navigating Among Command Levels .................................................................................................2-7

    CLI Command Structure ....................................................................................................................2-8

    Searching and Filtering Output ..........................................................................................................2-8

    Searching and Filtering Output from show commands................................................................ 2-8

    Searching and Filtering Output at the --More-- Prompt ............................................................. 2-10

    Using Special Characters in Regular Expressions .................................................................... 2-11

    Syntax Shortcuts ..............................................................................................................................2-13

    Saving Configuration Changes ........................................................................................................2-13

    Chapter 3Command List ......................................................................................... 3-1

    Complete Command List ..........................................................................................................................3-1

    Commands Listed by CLI Level ..............................................................................................................3-35

    EXEC Level ......................................................................................................................................3-35

    Privileged Level ................................................................................................................................3-35

    CONFIG Commands ........................................................................................................................3-39

    Global Level............................................................................................................................... 3-39

    Redundancy Level ..................................................................................................................... 3-50

    Interface Level ........................................................................................................................... 3-50

    Trunk Level................................................................................................................................ 3-56

    IP Access List Standard ............................................................................................................ 3-57

    IP Access List Extended ............................................................................................................ 3-58

    IPv6 Access List Level (HP devices that support IPv6 only) ..................................................... 3-58

    Router RIP Level ....................................................................................................................... 3-59

    IPv6 RIP Level (HP devices that support IPv6 only) ................................................................. 3-60

    Router OSPF Level ................................................................................................................... 3-60

    OSPF Version 3 Level (HP devices that support IPv6 only)...................................................... 3-62

    BGP Level ................................................................................................................................. 3-63

    Global BGP and BGP4 Unicast Address Family Level (HP devices that support IPv6 only) ... 3-64

    June 2005 iv

  • Contents

    BGP4 Multicast Address Family Level (HP devices that support IPv6 only) ............................. 3-66

    IPv6 BGP Unicast Address Family Level (HP devices that support IPv6 only) ........................ 3-67

    IP Tunnel Level.......................................................................................................................... 3-67

    MSDP Level............................................................................................................................... 3-68

    Router DVMRP Level ................................................................................................................ 3-68

    Router PIM Level....................................................................................................................... 3-69

    IPv6 Router PIM Level............................................................................................................... 3-70

    Broadcast Filter Level................................................................................................................ 3-70

    Multicast Filter Level.................................................................................................................. 3-71

    Router VRRP Level ................................................................................................................... 3-71

    Router VRRPE Level ................................................................................................................. 3-72

    VLAN Level................................................................................................................................ 3-72

    Metro Ring Level ....................................................................................................................... 3-74

    VSRP Level ............................................................................................................................... 3-75

    Topology Group Level ............................................................................................................... 3-75

    STP Group Level ....................................................................................................................... 3-76

    GVRP Level............................................................................................................................... 3-76

    802.1X Port Security Level ........................................................................................................ 3-77

    Real Server Level ...................................................................................................................... 3-78

    Application Port Level ................................................................................................................ 3-78

    Route Map Level ....................................................................................................................... 3-79

    Show Commands ...................................................................................................................... 3-79

    Chapter 4User EXEC Commands........................................................................... 4-1

    Chapter 5Privileged EXEC Commands ................................................................. 5-1

    Chapter 6Global CONFIG Commands ................................................................... 6-1

    Permit and Deny Policies .......................................................................................................... 6-51

    Additional Examples of Layer 2 MAC Filter Definitions ........................................................... 6-112

    Abbreviating the Address or Mask........................................................................................... 6-112

    June 2005 v

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Chapter 7Redundant Management Module

    CONFIG Commands .............................................................................. 7-1

    Chapter 8Interface Commands .............................................................................. 8-1

    Chapter 9Trunk Commands ................................................................................... 9-1

    Chapter 10IP Access Lists: Standard.................................................................... 10-1

    Chapter 11IP Access Lists: Extended ................................................................... 11-1

    Chapter 12IPv6 Access List Commands ............................................................... 12-1

    Chapter 13RIP Commands ..................................................................................... 13-1

    Chapter 14IPv6 RIP Commands ............................................................................. 14-1

    Chapter 15OSPF Commands.................................................................................. 15-1

    Chapter 16OSPF Version 3 Commands ................................................................ 16-1

    Chapter 17BGP4 Commands.................................................................................. 17-1

    Chapter 18Global BGP and BGP4 Unicast Address Family Commands ........... 18-1

    Chapter 19BGP4 Multicast Address Family Commands ..................................... 19-1

    Chapter 20IPv6 BGP Unicast Address Family Commands ................................. 20-1

    June 2005 vi

  • Contents

    Chapter 21IP Tunnel Commands ........................................................................... 21-1

    Chapter 22MSDP Commands ................................................................................. 22-1

    Chapter 23DVMRP Commands .............................................................................. 23-1

    Chapter 24PIM Commands ..................................................................................... 24-1

    Chapter 25IPv6 PIM Commands............................................................................. 25-1

    Chapter 26Broadcast and Multicast

    Filter Commands................................................................................... 26-1

    Broadcast Filter Commands ...................................................................................................................26-1

    Multicast Filter Commands .....................................................................................................................26-3

    June 2005 vii

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Chapter 27Route Map Commands ......................................................................... 27-1

    Chapter 28VRRP Commands ................................................................................. 28-1

    Chapter 29VRRPE Commands ............................................................................... 29-1

    Chapter 30VLAN Commands.................................................................................. 30-1

    Chapter 31Metro Ring Commands......................................................................... 31-1

    Chapter 32VSRP Commands.................................................................................. 32-1

    Chapter 33Topology Group Commands ............................................................... 33-1

    Chapter 34GVRP Commands ................................................................................. 34-1

    Chapter 35STP Group Commands......................................................................... 35-1

    Chapter 36802.1X Port Security Commands......................................................... 36-1

    Chapter 37MAC Port Security Commands............................................................ 37-1

    Chapter 38Real Server Commands........................................................................ 38-1

    Chapter 39Application Port Commands................................................................ 39-1

    Chapter 40Show Commands .................................................................................. 40-1

    Appendix A

    viii June 2005

  • Contents

    Commands That Require a Reload .......................................................A-1

    June 2005 ix

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    June 2005 x

  • Organization of Product Documentation

    NOTE: HP periodically updates the ProCurve 9300/9400 Series Routing Switch documentation. For the latest version of any of these publications, visit the ProCurve website at:

    http://www.procurve.com

    Click on Technical Support, then Product manuals.

    NOTE: All manuals listed below are available on the ProCurve website, and also on the Documentation CD shipped with your HP product.

    Installation and Basic Configuration Guide for ProCurve 9300 Series Routing Switches This is an electronic (PDF) guide containing product safety and EMC regulatory statements as well as installation and basic configuration information, and software and hardware specifications.

    Topics Specific to the 9300 Series Routing Switches Product mounting instructions

    Module installation

    Basic access and connectivity configuration (passwords, IP addresses)

    Redundant management module commands and file systems

    Cooling system commands and information

    Basic software feature configuration (SNMP, clock, mirror/monitor ports)

    Configuring for these features:

    Uni-Directional Link Detection (UDLD)

    Metro Ring Protocol (MRP)

    Virtual Switch Redundancy Protocol (VSRP)

    GVRP (dynamic VLANs)

    Software update instructions

    Hardware specs

    Software specs (e.g. RFC support, IEEE compliance)

    June 2005 xi

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Information on Configuring Features for 9300 Series and 9408sl Routing Switches Port settings

    VLANS

    Trunks

    Spanning Tree Protocol

    Syslog

    Quick Start Guide for ProCurve 9300 Series Routing Switches This is a printed guide you can use as an easy reference to the installation and product safety information needed for out-of-box setup, plus the general product safety and EMC regulatory statements of which you should be aware when installing and using a Routing Switch.

    Installation and Basic Configuration Guide for the ProCurve 9408sl Routing Switch This is a printed guide that describes the ProCurve 9408sl and provides procedures for installing modules and AC power supplies into the ProCurve 9408sl, cabling the 10-Gigabit Ethernet interface ports, and performing a basic configuration of the software.

    Topics Specific to the 9408sl Routing Switch Product overview and architecture

    Product mounting instructions

    Module installation

    Basic access and connectivity configuration (passwords, IP addresses)

    Management Module redundancy and file systems

    Interacting with the cooling system, switch fabric module, and interface modules

    Basic software feature configuration (SNMP, clock, mirror/monitor ports)

    Hardware maintenance instructions

    Software update instructions

    Hardware specs

    Safety and regulatory statements

    Software specs (e.g. RFC support, IEEE compliance)

    Advanced Configuration and Management Guide for ProCurve 9300/9400 Series Routing Switches This is an electronic (PDF) guide that contains advanced configuration information for routing protocols and Quality of Service (QoS). In addition, appendixes in this guide contain reference information for network monitoring, policies, and filters.

    Information on Configuring Features Quality of Service (QoS)

    Access Control Lists (ACLs)

    Rate limiting

    IPv4 routing

    RIP

    IP Multicast

    OSPF

    BGP4

    Multi-protocol BGP (MBGP)

    Network Address Translation (NAT)

    June 2005 xii

  • VRRP and VRRPE (VRRP extended)

    IPX routing

    AppleTalk routing

    Route health injection

    RMON, NetFlow, and sFlow monitoring

    IPv6 Configuration Guide for the ProCurve 9408sl Routing Switch This is an electronic (PDF) guide that describes the IPv6 software and features. It provides conceptual information about IPv6 addressing and explains how to configure basic IPv6 connectivity and the IPv6 routing protocols. The software procedures explain how to perform tasks using the CLI.

    Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches This is an electronic (PDF) guide that provides a dictionary of CLI commands and syntax.

    Security Guide for ProCurve 9300/9400 Series Routing Switches This is an electronic (PDF) guide that provides procedures for securing management access to HP devices and for protecting against Denial of Service (DoS) attacks.

    Diagnostic Guide for ProCurve 9300/9400 Series Routing Switches This is an electronic (PDF) guide that describes the diagnostic commands available on HP devices. The software procedures show how to perform tasks using the Command Line Interface (CLI).

    Removing and Installing XENPAK Optics This is a printed instruction sheet describing the correct preparation and procedure for removing and installing XENPAK optics on the 10-Gigabit Ethernet modules.

    Read Me First The "Read Me First" document, printed on bright yellow paper, is included with every chassis and module. It contains an overview of software release information, a brief "Getting Started" section, an included parts list, troubleshooting tips, operating notes, and other information that is not included elsewhere in the product documentation. It also includes:

    software update instructions

    operating notes for this release

    Release Notes These documents describe features and other information that becomes available between revisions of the main product guides. New releases of such documents will be available on HP's ProCurve website. To register to receive email notice from HP when a new software release is available, visit:

    http://www.procurve.com

    In the "My Procurve" box on the right, click on "Register".

    Product Documentation CD: A Tool for Finding Specific Information and/or Printing Selected Pages This CD is shipped with your ProCurve Routing Switch product and provides the following:

    A README file describing the CD contents and use, including easy instructions on how to search the book files for specific information

    A Contents file to give you easy access to the documentation on the CD

    Separate PDF files of the individual chapters and appendixes in the major guides, enabling you to easily print individual chapters, appendixes, and selected pages

    Single PDF files for each of the major guides, enabling you to use the Adobe Acrobat Reader to easily search for detailed information

    Additional files. These may include such items as additional Read Me files and release notes.

    June 2005 xiii

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    xiv June 2005

  • Chapter 1 Getting Started

    Introduction This reference describes the Command Line Interface (CLI) for the following ProCurve Routing Switches.

    ProCurve Routing Switch 9315M

    ProCurve Routing Switch 9308M

    ProCurve Routing Switch 9304M

    ProCurve Routing Switch9408sl

    NOTE: This reference lists all the commands that appear at each command level for users with super-user access. If you are logged on with port-configuration access or read-only access, some of these commands will not be displayed and will not be available.

    Software Versions Covered This edition describes software release 07.8.00a for the following ProCurve products:

    9304M

    9308M

    9315M

    This edition also describes software release 01.0.02 for the ProCurve 9408sl Routing Switch.

    NOTE: The software release for the 9408sl is 02.1.00. See the Release Notes for the most current information, which supercedes the information in this guide.

    Audience This manual is designed for system administrators with a working knowledge of Layer 2 and Layer 3 switching and routing.

    If you are using a ProCurve Routing Switch, you should be familiar with the following protocols if applicable to your networkIP, RIP, OSPF, BGP4, IGMP, PIM, DVMRP, IPX, AppleTalk, and VRRP.

    June 2005 1 - 1

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Conventions This guide uses the following typographical conventions:

    Italic highlights the title of another publication and occasionally emphasizes a word or phrase.

    Bold highlights a CLI command.

    Bold Italic highlights a term that is being defined.

    Underline highlights a link on the Web management interface.

    Capitals highlights field names and buttons that appear in the Web management interface.

    NOTE: A note emphasizes an important fact or calls your attention to a dependency.

    WARNING: A warning calls your attention to a possible hazard that can cause injury or death.

    CAUTION: A caution calls your attention to either a possible hazard that can damage equipment or an action that can produce an operating problem or other unwanted results.

    Terminology The following table defines basic product terms used in this guide.

    Term

    chassis

    or

    Chassis device

    EP

    and

    Standard

    Routing Switch

    or

    router

    Switch

    ProCurveRS#

    Definition

    A Routing Switch that accepts optional modules or power supplies. The ProCurve 9304M, 9308M, 9315M, and 9408sl Routing Switches are Chassis devices.

    9300 Series Chassis devices can be EP or Standard devices, depending on whether the management module is an EP or Standard module.

    A Layer 2 and Layer 3 device that switches and routes network traffic. The term router is sometimes used in this document in descriptions of a Routing Switchs Layer 3 routing protocol features.

    A Layer 2 device that switches network traffic.

    An example Command Line Interface (CLI) prompt. Actual prompts show the product number for the device, such as HP9304#.

    Support and Warranty Information Refer to Support is as Close as the World Wide Web, which was shipped with your ProCurve Routing Switch.

    Related Publications Refer to the Organization of Product Documentation on page xi for a list of publications for your ProCurve Routing Switch.

    1 - 2 June 2005

  • Chapter 2 Using the Command Line Interface

    The CLI is a text-based interface for configuring and monitoring ProCurve Routing Switches. You can access the CLI through either a direct serial connection to the device or through a Telnet session.

    The commands in the CLI are organized into the following levels:

    User EXEC Lets you display information and perform basic tasks such as pings and trace routes.

    Privileged EXEC Lets you use the same commands as those at the User EXEC level plus configuration commands that do not require saving the changes to the system-config file.

    CONFIG Lets you make configuration changes to the device. To save the changes across reboots, you need to save them to the system-config file. The CONFIG level contains sub-levels for individual ports, for VLANs, for routing protocols, and other configuration areas.

    NOTE: By default, any user who can open a serial or Telnet connection to the HP device can access all these CLI levels. To secure access, you can configure Enable passwords or local user accounts, or you can configure the device to use Access Control Lists (ACLs), a RADIUS server, or a TACACS/TACACS+ server for authentication. See the Security Guide for ProCurve 9300/9400 Series Routing Switches.

    To display a list of available commands or command options, enter ? or press Tab. If you have not entered part of a command at the command prompt, all the commands supported at the current CLI level are listed. If you enter part of a command, then enter ? or press Tab, the CLI lists the options you can enter at the point in the command string.

    The CLI supports command completion, so you do not need to enter the entire name of a command or option. As long as you enter enough characters of the command or option name to avoid ambiguity with other commands or options, the CLI understands what you are typing.

    The CLI supports the following line editing commands. To enter a line-editing command, use the CTRL-key combination for the command by pressing and holding the CTRL key, then pressing the letter associated with the command.

    Table 2.1: CLI Line-Editing Commands

    Ctrl-Key Combination Description

    Ctrl-A Moves to the first character on the command line.

    Ctrl-B Moves the cursor back one character.

    June 2005 2 - 1

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 2.1: CLI Line-Editing Commands (Continued)

    Ctrl-Key Combination

    Ctrl-C

    Ctrl-D

    Ctrl-E

    Ctrl-F

    Ctrl-K

    Ctrl-L; Ctrl-R

    Ctrl-N

    Ctrl-P

    Ctrl-U; Ctrl-X

    Ctrl-W

    Ctrl-Z

    Description

    Escapes and terminates command prompts and ongoing tasks (such as lengthy displays), and displays a fresh command prompt.

    Deletes the character at the cursor.

    Moves to the end of the current command line.

    Moves the cursor forward one character.

    Deletes all characters from the cursor to the end of the command line.

    Repeats the current command line on a new line.

    Enters the next command line in the history buffer.

    Enters the previous command line in the history buffer.

    Deletes all characters from the cursor to the beginning of the command line.

    Deletes the last word you typed.

    Moves from any CONFIG level of the CLI to the Privileged EXEC level; at the Privileged EXEC level, moves to the User EXEC level.

    EXEC Commands There are two different levels of EXEC commands, the User Level and the Privileged Level. The User level commands are at the top of the CLI hierarchy. These are the first commands that you have access to when connected to the device through the CLI. At this level, you can view basic system information and verify connectivity but cannot make any changes to the device configuration. To make changes to the configuration, you must move to other levels of the CLI hierarchy. This is accomplished by the User EXEC level command enable at initial log-on. This command takes you to the Privileged EXEC level, from which you can reach the configuration command levels.

    Privileged Level The Privileged EXEC level commands primarily enable you to transfer and store software images and

    configuration files between the network and the system, and review the configuration.

    You reach this level by entering enable [] or enable at the User EXEC level.

    CONFIG Commands CONFIG commands modify the configuration of a Procurve Routing Switch. This reference describes the following CONFIG CLI levels.

    Global Level The global CONFIG level allows you to globally apply or modify parameters for ports on the device. You reach this level by entering configure terminal at the privileged EXEC level.

    2 - 2 June 2005

  • Using the Command Line Interface

    Redundancy Level This redundancy level allows you to configure redundancy parameters for redundant management modules. You reach this level by entering the redundancy command at the global CONFIG level.

    Interface Level The interface level allows you to assign or modify specific port parameters on a port-by-port basis. You reach this level by entering interface ethernet , interface loopback , or interface ve at the global CONFIG level.

    Trunk Level The trunk level allows you to change parameters for statically-configured trunk groups. You reach this level by entering a trunk command with the appropriate port parameters.

    IPV6 Access List Level The IPv6 access list level allows you to configure standard and extended ACLs for IPv6. You reach this level by entering the ipv6 access-list command at the global CONFIG level.

    Router RIP Level The RIP level allows you to configure parameters for the RIP routing protocol. You reach this level by entering the router rip command at the global CONFIG level.

    IPv6 RIP Level(HP devices that support IPv6 only) The IPv6 RIP level allows you to configure parameters for the IPv6 RIP routing protocol. You reach this level by entering the ipv6 router rip command at the RIP level.

    Router OSPF Level The OSPF level allows you to configure parameters for the OSPF routing protocol. You reach this level by entering the router ospf command at the global CONFIG level.

    OSPF Version 3 Level (HP devices that support IPv6 only) The OSPF version 3 level allows you to configure parameters for the OSPF version 3 routing protocol. You reach this level by entering the ipv6 router ospf command at the OSPF level.

    BGP Level The BGP level allows you to configure Routing Switches for Border Gateway Protocol version 4 (BGP4). You reach this level by entering the router bgp command at the global CONFIG level.

    Global BGP and BGP4 Unicast Address Family Level The global BGP and BGP4 unicast address family levels are present only on HP devices that support IPv6. The global BGP level allows you to configure the BGP routing protocol. The BGP4 unicast address family level allows you to configure a BGP4 unicast route. For backward compatibility, you can currently access BGP4 unicast address family commands at both global BGP configuration and BGP4 unicast address family configuration levels. Therefore, the global BGP and BGP4 unicast address family commands are documented together.

    You reach the global BGP level by entering the router bgp command at the global CONFIG level. You reach the BGP4 unicast address family level by entering the address-family ipv4 unicast command at the global BGP level.

    June 2005 2 - 3

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    BGP4 Multicast Address Family Level (HP devices that support IPv6 only) The BGP4 multicast address family level allows you to configure BGP4 multicast routes. You reach this level by entering the address-family ipv4 multicast command at the global BGP, BGP4 unicast address family, or IPv6 BGP unicast address family levels.

    IPv6 BGP Unicast Address Family Level (HP devices that support IPv6 only) The IPv6 BGP unicast address family level allows you to configure IPv6 BGP unicast routes. You reach this level by entering the address-family ipv6 unicast command at the global BGP, BGP4 unicast address family, or BGP4 multicast address family levels.

    IP Tunnel Level The IP tunnel level allows you to define parameters for IP-in-IP tunnels to pass data through non-DVMRP and non-PIM IP multicast routers.

    You reach this level by entering the ip tunnel command at the interface CONFIG level.

    Router MSDP Level The MSDP level allows you to configure details for the Multicast Source Discovery Protocol (MSDP). You reach this level by entering the router msdp command at the global CONFIG level.

    Router DVMRP Level The DVMRP level allows you to configure details for the DVMRP multicast protocol. You reach this level by entering the router dvmrp command at the global CONFIG level.

    Router PIM Level The PIM level allows you to configure parameters for the Protocol Independent Multicast (PIM) routing protocol. You reach this level by entering the router pim command at the global CONFIG level.

    IPv6 Router PIM Level (HP devices that support IPv6 only) The IPv6 Router PIM level allows you to configure parameters for the Protocol Independent Multicast (PIM) routing protocol in IPv6. You reach this level by entering the ipv6 router pim command at the global CONFIG level.

    Broadcast Filter Level The broadcast filter level allows you to assign broadcast filters to specific ports. You reach this level by entering broadcast filter... at the global CONFIG level.

    Multicast Filter Level The multicast filter level allows you to assign multicast filters to specific ports. You reach this level by entering multicast filter... at the global CONFIG level.

    Route Map Level The Route Map level allows you to configure parameters for a BGP4 route map. You reach this level by entering the route-map command at the global CONFIG level.

    Router VRRP Level The VRRP level allows you to configure parameters for the Virtual Router Redundancy Protocol (VRRP). You reach this level by entering the router vrrp command at the global CONFIG level, then entering the ip vrrp vrid command at the interface configuration level.

    2 - 4 June 2005

  • Using the Command Line Interface

    Router VRRPE Level The VRRPE level allows you to configure parameters for VRRP Extended. You reach this level by entering the router vrrp-extended command at the global CONFIG level, then entering the ip vrrp-extended vrid command at the interface configuration level.

    VLAN Level Policy-based VLANs allow you to assign VLANs on a protocol (IP, IPX, Decnet, AppleTalk, NetBIOS, Others), subnet (IP sub-net and IPX network), AppleTalk cable, port, or 802.1q tagged basis.

    You reach this level by entering the vlan by port command at the Global CONFIG Level.

    Metro Ring Level Metro rings provide Layer 2 connectivity and fast failover in ring topologies.

    You reach this level by entering the metro-ring command at the Global CONFIG Level.

    VSRP Level The VSRP level allows you to configure parameters for the Virtual Switch Redundancy Protocol (VSRP). You reach this level by entering the vsrp vrid command at the VLAN configuration level, then entering the vsrp vrid command at the VLAN configuration level.

    Topology Group Level A topology group enables you to control the Layer 2 protocol configuration and Layer 2 state of a set of ports in multiple VLANs based on the configuration and states of those ports in a single master VLAN. One instance of the Layer 2 protocol controls all the VLANs.

    You reach this level by entering the topology-group command at the Global CONFIG Level.

    STP Group Level STP groups enable you to manage multiple port-based VLANs using the same spanning tree.

    You reach this level by entering the stp-group command at the Global CONFIG Level.

    GVRP Level GARP VLAN Registration Protocol (GVRP) is a Generic Attribute Registration Protocol (GARP) application that provides VLAN registration service by means of dynamic configuration (registration) and distribution of VLAN membership information.

    You reach the GVRP level by entering the gvrp-enable command at the Global CONFIG Level.

    Real Server Level The Real Server level allows you to configure router-based health check parameters for a Routing Switch to assist with Globally-distributed Server Load Balancing (SLB). See the Route Health Injection chapter of the Advanced Configuration and Management Guide for ProCurve 9300/9400 Series Routing Switches. You reach this level by entering the server real... command at the global CONFIG level.

    Application Port Level The Application Port level allows you to configure health check parameters for a TCP HTTP port. The commands at this level apply only when you are configuring a Routing Switch to assist third-party SLBs or Web servers with globally-distributed SLB. See the Route Health Injection chapter of the Advanced Configuration and Management Guide for ProCurve 9300/9400 Series Routing Switches. You reach this level by entering the server port http | command at the global CONFIG level.

    June 2005 2 - 5

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    NOTE: If you enter server port ?, numerous well-known port names are listed. The current software release supports only HTTP ports.

    Accessing the CLI The CLI can be accessed through both serial and Telnet connections. For initial log on, you must use a serial connection. Once an IP address is assigned, you can access the CLI through Telnet.

    NOTE: When accessing the CLI through Telnet, you are prompted for a password. By default, the password required is the password you enter for general access at initial setup. You also have the option of assigning a separate password for Telnet access with the enable telnet password command, found at the Global Level.

    NOTE: At initial log on, all you need to do is type enable at the prompt, then press Return. You only need to enter a password after a permanent password is entered at the Global CONFIG Level of the CLI.

    Once connectivity to the device is established, you will see the prompt: ProCurveRS>

    At this prompt ( > ), you are at the user EXEC level of the CLI command structure.

    To reach the Global CONFIG Level, the uppermost level of the CONFIG commands, enter the following

    commands:

    ProCurveRS> enable User Level-EXEC commands

    ProCurveRS# configure terminalPrivileged Level-EXEC commands

    ProCurveRS(config)# Global Level-CONFIG commands

    You can then reach all other levels of the CONFIG command structure from this point.

    2 - 6 June 2005

  • Using the Command Line Interface

    NOTE: The CLI prompt will change at each level of the CONFIG command structure, to easily identify the current level:

    ProCurveRS> User Level EXEC Command

    ProCurveRS# Privileged Level EXEC Command

    ProCurveRS(config)#Global Level CONFIG Command

    ProCurveRS(config-if-5/1)#Interface Level CONFIG Command

    ProCurveRS(config-lbif-1)#Loopback Interface CONFIG Command

    ProCurveRS(config-ve-1)#Virtual Interface CONFIG Command

    ProCurveRS(config-trunk-4/1-4/8)#Trunk group CONFIG Command

    ProCurveRS(config-if-tunnel)#IP Tunnel Level CONFIG Command

    ProCurveRS(config-bcast-filter-id-1)#Broadcast Filter Level CONFIG Command

    ProCurveRS(config-mcast-filter-id-1)#Multicast Filter Level CONFIG Command

    ProCurveRS(config-bgp-router)#BGP Level CONFIG Command

    ProCurveRS(config-dvmrp-router)#DVMRP Level CONFIG Command

    ProCurveRS(config-ospf-router)#OSPF Level CONFIG Command

    ProCurveRS(config-pim-router)#PIM Level CONFIG Command

    ProCurveRS(config-msdp-router)#MSDP Level CONFIG Command

    ProCurveRS(config-redundancy)#Redundant Management Module CONFIG Command

    ProCurveRS(config-rip-router)#RIP Level CONFIG Command

    ProCurveRS(config-rs-realservername)#Real Server Level CONFIG Command

    ProCurveRS(config-port-80)#Application Port CONFIG Command

    ProCurveRS(config-bgp-routemap Map_Name)#Route Map Level CONFIG Command

    ProCurveRS(config-vlan-1)#VLAN Port-based Level CONFIG Command

    ProCurveRS(config-vlan-atalk-proto)#VLAN Protocol Level CONFIG Command

    ProCurveRS(config-stp-group-1)#STP Group CONFIG Command

    ProCurveRS(config-gvrp)#GVRP CONFIG Command

    ProCurveRS(config-cpu-protection)#Control Plane Security CONFIG Command

    NOTE: The CLI prompt at the interface level includes the port speed. The speed is one of the following:

    e100 The interface is a 10/100 port.

    e1000 The interface is a Gigabit port.

    For simplicity, the port speeds sometimes are not shown in example Interface level prompts in this manual.

    Navigating Among Command Levels To reach other CLI command levels, you need to enter certain commands. At each level there is a launch command that allows you to move either up or down to the next level.

    June 2005 2 - 7

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    CLI Command Structure Many CLI commands may require textual or numeral input as part of the command. These fields are either required or optional depending on how the information is bracketed. For clarity, a few CLI command examples are explained below.

    EXAMPLE:

    Syntax: deny redistribute all | bgp | rip | static address [match-metric | set-metric ]

    When an item is bracketed with < > symbols, the information requested is a variable and required.

    When an item is not enclosed by < > or [ ] symbols, the item is a required keyword.

    When an item is bracketed with [ ] symbols, the information requested is optional.

    When two or more options are separated by a vertical bar, | , you must enter one of the options as part of the command.

    EXAMPLE:

    Syntax: priority normal | high means enter either priority normal or priority high

    For example, the command syntax above requires that either normal or high be entered as part of the command.

    To get a quick display of available options at a CLI level or for the next option in a command string, enter a question mark (?) at the prompt or press TAB.

    EXAMPLE:

    To view all available commands at the user EXEC level, enter the following or press TAB at the User EXEC CLI level:

    ProCurveRS> ?

    enable

    exit

    fastboot

    ping

    show

    stop-trace-route

    traceroute

    You also can use the question mark (?) with an individual command, to see all available options or to check

    context.

    EXAMPLE:

    To view possible copy command options, enter the following:

    ProCurveRS# copy ?

    flash

    running-config

    startup-config

    tftp

    ProCurveRS# copy flash ?

    tftp

    Searching and Filtering Output You can filter CLI output from show commands and at the --More-- prompt. You can search for individual characters, strings, or construct complex regular expressions to filter the output.

    Searching and Filtering Output from show commands

    You can filter output from show commands to display lines containing a specified string, lines that do not contain a specified string, or output starting with a line containing a specified string. The search string is a regular expression consisting of a single character or string of characters. You can use special characters to construct

    2 - 8 June 2005

  • Using the Command Line Interface

    complex regular expressions. See Using Special Characters in Regular Expressions on page 2-11 for information on special characters used with regular expressions.

    Displaying Lines Containing a Specified String The following command filters the output of the show interface command for port 3/11 so it displays only lines containing the word Internet. This command can be used to display the IP address of the interface.

    ProCurveRS# show interface e 3/11 | include Internet

    Internet address is 192.168.1.11/24, MTU 1518 bytes, encapsulation ethernet

    Syntax: | include

    NOTE: The vertical bar ( | ) is part of the command.

    Note that the regular expression specified as the search string is case sensitive. In the example above, a search string of Internet would match the line containing the IP address, but a search string of internet would not.

    Displaying Lines That Do Not Contain a Specified String The following command filters the output of the show who command so it displays only lines that do not contain the word closed. This command can be used to display open connections to the HP device.

    ProCurveRS# show who | exclude closed

    Console connections:

    established

    you are connecting to this session

    2 seconds in idle

    Telnet connections (inbound):

    1 established, client ip address 192.168.9.37

    27 seconds in idle

    Telnet connection (outbound):

    SSH connections:

    Syntax: | exclude

    Displaying Lines Starting with a Specified String The following command filters the output of the show who command so it displays output starting with the first line that contains the word SSH. This command can be used to display information about SSH connections to the HP device.

    ProCurveRS# show who | begin SSH

    SSH connections:

    1 established, client ip address 192.168.9.210

    7 seconds in idle 2 closed 3 closed 4 closed 5 closed

    Syntax: | begin

    June 2005 2 - 9

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Searching and Filtering Output at the --More-- Prompt

    The --More-- prompt is displayed when output extends beyond a single page. From this prompt, you can press the Space bar to display the next page, the Return or Enter key to display the next line, or Ctrl-C or Q to cancel the display. You can also search and filter output from this prompt. For example:

    ProCurveRS# ? appletalk-ping Ping AppleTalk node boot Boot system from bootp/tftp server/flash image cd Change flash card working slot or current directory

    chdir Change flash card working slot or current directory clear Clear table/statistics/keys configure Enter configuration mode copy Copy between flash, flash card, tftp, config/code

    debug Enable debugging functions (see also 'undebug') dir List flash card files

    disable Disable a module before removing it enable Enable a disabled module erase Erase image/configuration from flash exit Exit Privileged mode

    fastboot Select fast-reload option format Format flash card gignpa Gigabit processor commands kill Kill active CLI session

    --More--, next page: Space, next line: Return key, quit: Control-c

    At the --More-- prompt, you can press the forward slash key ( / ) and then enter a search string. The HP device displays output starting from the first line that contains the search string, similar to the begin option for show commands. For example:

    --More--, next page: Space, next line: Return key, quit: Control-c

    /telnet

    The results of the search are displayed:

    searching... telnet Telnet by name or IP address temperature temperature sensor commands terminal display syslog traceroute TraceRoute to IP node undebug Disable debugging functions (see also 'debug') undelete Undelete flash card files whois WHOIS lookup write Write running configuration to flash or terminal

    2 - 10 June 2005

  • Using the Command Line Interface

    To display lines containing only a specified search string (similar to the include option for show commands) press the plus sign key ( + ) at the --More-- prompt and then enter the search string.

    --More--, next page: Space, next line: Return key, quit: Control-c

    +telnet

    The filtered results are displayed:

    filtering...

    telnet Telnet by name or IP address

    To display lines that do not contain a specified search string (similar to the exclude option for show commands) press the minus sign key ( - ) at the --More-- prompt and then enter the search string.

    --More--, next page: Space, next line: Return key, quit: Control-c

    -telnet

    The filtered results are displayed:

    filtering... sync-standby Synchronize active and standby module temperature temperature sensor commands terminal display syslog traceroute TraceRoute to IP node undebug Disable debugging functions (see also 'debug') undelete Undelete flash card files whois WHOIS lookup write Write running configuration to flash or terminal

    As with the commands for filtering output from show commands, the search string is a regular expression consisting of a single character or string of characters. You can use special characters to construct complex regular expressions. See the next section for information on special characters used with regular expressions.

    Using Special Characters in Regular Expressions

    You use a regular expression to specify a single character or multiple characters as a search string. In addition, you can include special characters that influence the way the software matches the output against the search string. These special characters are listed in the following table.

    Table 2.2: Special Characters for Regular Expressions

    Character

    .

    *

    Operation

    The period matches on any single character, including a blank space.

    For example, the following regular expression matches aaz, abz, acz, and so on, but not just az:

    a.z

    The asterisk matches on zero or more sequential instances of a pattern.

    For example, the following regular expression matches output that contains the string

    abc, followed by zero or more Xs:

    abcX*

    June 2005 2 - 11

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 2.2: Special Characters for Regular Expressions (Continued)

    Character Operation

    + The plus sign matches on one or more sequential instances of a pattern.

    For example, the following regular expression matches output that contains "de", followed

    by a sequence of gs, such as deg, degg, deggg, and so on:

    deg+

    ? The question mark matches on zero occurrences or one occurrence of a pattern.

    For example, the following regular expression matches output that contains "dg" or "deg":

    de?g

    Note: Normally when you type a question mark, the CLI lists the commands or options at

    that CLI level that begin with the character or string you entered. However, if you enter Ctrl-V and then type a question mark, the question mark is inserted into the command line, allowing you to use it as part of a regular expression.

    ^ A caret (when not used within brackets) matches on the beginning of an input string.

    For example, the following regular expression matches output that begins with deg:

    ^deg

    $ A dollar sign matches on the end of an input string.

    For example, the following regular expression matches output that ends with deg:

    deg$

    _ An underscore matches on one or more of the following:

    , (comma)

    { (left curly brace)

    } (right curly brace)

    ( (left parenthesis)

    ) (right parenthesis)

    The beginning of the input string

    The end of the input string

    A blank space

    For example, the following regular expression matches on 100 but not on 1002, 2100,

    and so on.

    _100_

    2 - 12 June 2005

  • Using the Command Line Interface

    Table 2.2: Special Characters for Regular Expressions (Continued)

    Character Operation

    [ ] Square brackets enclose a range of single-character patterns.

    For example, the following regular expression matches output that contains 1, 2, 3, 4,

    or 5:

    [1-5]

    You can use the following expression symbols within the brackets. These symbols are

    allowed only inside the brackets.

    ^ The caret matches on any characters except the ones in the brackets. For example, the following regular expression matches output that does not contain 1, 2, 3, 4, or 5:

    [^1-5]

    - The hyphen separates the beginning and ending of a range of characters. A match occurs if any of the characters within the range is present. See the example above.

    | A vertical bar separates two alternative values or sets of values. The output can match one

    or the other value.

    For example, the following regular expression matches output that contains either abc or

    defg:

    abc|defg

    ( ) Parentheses allow you to create complex expressions.

    For example, the following complex expression matches on abc, abcabc, or defg, but

    not on abcdefgdefg:

    ((abc)+)|((defg)?)

    If you want to filter for a special character instead of using the special character as described in the table above, enter \ (backslash) in front of the character. For example, to filter on output containing an asterisk, enter the asterisk portion of the regular expression as \*.

    ProCurveRS# show ip route bgp | include \*

    Syntax Shortcuts A command or parameter can be abbreviated as long as enough text is entered to distinguish it from other commands at that level. For example, given the possible commands copy tftp and config tftp, possible shortcuts are cop tftp and con tftp respectively. In this case, co does not properly distinguish the two commands.

    Saving Configuration Changes You can make configuration changes while the device is running. The type of configuration change determines whether or not it becomes effective immediately or requires a save to flash (write memory) and reset of the system (reload), before it becomes active.

    This approach in adopting configuration changes:

    Allows you to make configuration changes to the operating or running configuration of the device to address a short-term requirement or validate a configuration without overwriting the permanent configuration file, the startup configuration, that is saved in the system flash, and;

    Ensures that dependent or related configuration changes are all cut in at the same time.

    June 2005 2 - 13

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    In all cases, if you want to make the changes permanent, you need to save the changes to flash using the write memory command. When you save the configuration changes to flash, this will become the configuration that is initiated and run at system boot.

    NOTE: Most configuration changes are dynamic and thus do not require a software reload. If a command requires a software reload to take effect, the documentation states this.

    2 - 14 June 2005

  • Chapter 3 Command List

    This chapter lists all the commands in the CLI. The commands are listed in two ways:

    All commands are listed together in a single alphabetic list. See Complete Command List below.

    Commands are listed separately for each CLI level (for example, global CONFIG level, BGP4 level, and so on). See Commands Listed by CLI Level on page 3-35.

    In each list, the page numbers in this reference that describe the commands are listed.

    Complete Command List

    Table 3.1: Complete Layer 2/3 Command List

    10gig copy 5-1

    aaa accounting 6-1

    aaa authentication 6-1

    aaa authorization 6-3

    access-list delete 6-3

    access-list deny (extended) 6-4

    access-list deny (standard) 6-9

    access-list insert 6-10

    access-list permit (extended) 6-11

    access-list permit (standard) 6-15

    access-list rate-limit 6-16

    access-list remark 6-17

    access-list replace 6-17

    acl-denied-icmp-msg 6-18

    activate 28-1, 29-1, 32-1

    June 2005 3 - 1

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    active-management 7-1

    address-family 18-1, 18-1, 19-1, 20-1

    address-family ipv4 unicast 20-1

    address-family ipv6 unicast 19-1

    address-filter 17-1, 18-2

    add-vlan 30-1

    adjacency-check 20-1

    advertise backup 28-1, 29-1, 32-1

    age 37-1

    aggregate-address 17-2, 18-3, 19-2, 20-2

    aggregated-vlan 6-18

    aggregated-vlan-copy-cos 6-19

    all-client 6-19

    always-compare-med 17-2, 18-4

    appletalk address 8-1

    appletalk arp-age 6-20

    appletalk arp-retransmit-count 6-20

    appletalk arp-retransmit-interval 6-20

    appletalk cable-range 8-1

    appletalk deny 8-1

    appletalk deny additional-zones 8-2

    appletalk glean-packets 6-20

    appletalk permit 8-2

    appletalk qos socket 6-20

    appletalk routing 8-2

    appletalk rtmp-update-interval 6-21

    appletalk zip-query-interval 6-21

    appletalk zone-name 8-3

    appletalk-cable-vlan 30-1

    appletalk-ping 4-1

    area 15-1, 16-1

    area | virtual-link 15-2

    3 - 2 June 2005

  • Command List

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    area | virtual-link

    area range 15-4

    arp 6-21

    as-path-filter 17-3, 18-4

    as-path-ignore 17-3, 18-5

    atalk-proto 30-2

    auto-acl-rebind 6-22

    auto-cost reference-bandwidth 15-4, 16-3

    auto-summary 17-4, 18-5

    autosave 37-1

    backup 28-1, 29-1, 32-1

    backup-hello-interval 28-1, 29-1, 32-2

    banner exec 6-22

    banner incoming 6-22

    banner motd 6-23

    bgp-redistribute-internal 17-4, 18-5

    block-applicant 34-1

    block-learning 34-1

    boot system bootp 5-1

    boot system flash primary 5-2

    boot system flash secondary 5-2

    boot system tftp 5-2

    bootp-relay-max-hops 6-24

    broadcast filter 6-24

    broadcast limit 6-25, 8-3

    bsr-candidate 24-1

    cam-partition 6-26

    cdp enable 8-3

    cdp run 6-27

    chassis name 6-27

    chassis poll-time 6-27

    chassis trap-log 6-28

    June 2005 3 - 3

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    clear acl-on-arp 5-3

    clear appletalk arp 5-3

    clear appletalk cache 5-3

    clear appletalk route 5-3

    clear appletalk traffic 5-3

    clear arp 5-4

    clear dvmrp cache 5-5

    clear dvmrp flow 5-5

    clear dvmrp route 5-5

    clear fdp counters 5-5

    clear fdp table 5-5

    clear gvrp statistics 5-5

    clear igmp traffic 5-6

    clear ip acl-traffic 5-6

    clear ip bgp neighbor 5-6

    clear ip bgp routes 5-8

    clear ip bgp traffic 5-8

    clear ip cache 5-8

    clear ip dr-aggregate 5-8

    clear ip msdp peer 5-8

    clear ip msdp sa-cache 5-9

    clear ip msdp statistics 5-9

    clear ip multicast 5-9

    clear ip multicast statistics 5-11

    clear ip nat 5-11

    clear ip route 5-12

    clear ip rpf 5-12

    clear ip vrrp-stat 5-12

    clear ipv6 access-list 5-12

    clear ipv6 bgp dampening 5-12

    clear ipv6 bgp flap-statistics 5-13

    clear ipv6 bgp local routes 5-13

    clear ipv6 bgp neighbor 5-13

    3 - 4 June 2005

  • Command List

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    clear ipv6 bgp routes 5-16

    clear ipv6 bgp traffic 5-16

    clear ipv6 cache 5-16

    clear ipv6 flows 5-17

    clear ipv6 mld traffic 5-17

    clear ipv6 neighbor 5-17

    clear ipv6 rip route 5-18

    clear ipv6 route 5-18

    clear ipv6 traffic 5-18

    clear ipv6 tunnel 5-18

    clear ipx cache 5-18

    clear ipx route 5-19

    clear link-aggregate 5-19

    clear link-keepalive statistics 5-19

    clear logging 5-19

    clear mac vpls 5-20

    clear mac-address 5-20

    clear pim cache 5-20

    clear pim counters 5-20

    clear pim rp-map 5-20

    clear public-key 5-21

    clear statistics 5-21

    clear statistics dos-attack 5-21

    clear statistics rate-counters 5-22

    clear statistics rate-limit 5-22

    clear web-connection 5-22

    client-to-client-reflection 17-4, 18-6, 19-3, 20-3

    clock summer-time 6-28

    clock timezone 6-28

    cluster-id 17-5, 18-6

    community-filter 17-5, 18-6

    compare-routerid 17-6, 18-7

    confederation 17-6, 18-8

    June 2005 3 - 5

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    configure terminal

    config-trunk-ind

    confirm-port-up

    console

    control-timer

    copy flash flash

    copy flash tftp

    copy running-config tftp

    copy startup-config tftp

    copy tftp flash

    copy tftp running-config

    copy tftp startup-config

    cpupro-action hardware mode

    cpupro-action hardware ve-not-to-cpu

    cpupro-action hardware-flooding

    cpupro-action quick-aging

    cpupro-action sys cam

    cpupro-action sys cpu

    cpu-usage

    crypto key

    crypto random-number-seed

    crypto-ssl certificate generate

    crypto-ssl certificate zeroize

    dampening

    database-overflow-interval

    dead-interval

    decnet-proto

    default-gateway

    default-information-originate

    default-local-preference

    default-max-frame-size

    default-metric

    default-timers

    5-23

    9-1

    6-29

    6-29

    53-1

    5-23

    5-23

    5-24

    5-24

    5-25

    5-25

    5-26

    6-30

    6-30

    6-30

    6-31

    6-31

    6-31

    6-32

    6-32

    6-32

    6-33

    6-33

    17-6, 18-8, 19-3, 20-3

    15-5, 16-4

    28-1, 29-1, 32-2

    30-2

    23-1, 30-2

    15-6, 16-4, 19-117-7, 18-9, 19-4, 20-4

    17-7, 18-9

    6-33

    13-1, 15-7, 16-5, 19-2, 17-8, 18-9, 19-4, 20-4

    34-1

    3 - 6 June 2005

  • Command List

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    default-vlan-id 6-34, 30-3

    deny 10-1, 11-1, 12-1

    deny icmp 12-2

    deny tcp 12-3

    deny udp 12-5

    deny redistribute 15-7, 13-1

    deny 12-6

    disable 5-27, 8-3, 9-2, 29-2, 32-3

    disable-dvmrp 23-1

    disable-pim 24-1

    disable-partial-spf-opt 17-3

    distance 14-1, 15-8, 16-6, 19-3, 17-8, 18-10

    distribute-list 14-1, 15-8

    distribute-list prefix-list 16-6

    distribute-list route-map 16-7

    dot1x-enable 6-34

    dot1x initialize 5-27

    dot1x multiple-hosts 8-4

    dot1x port-control 8-4

    dot1x re-authenticate 5-28

    dual-mode 8-4

    enable 5-28, 6-35, 8-5, 9-2, 29-2, 31-1, 32-3, 36-2, 37-1

    enable 4-1

    enable 4-2

    enable aaa console 6-35

    enable password-display 6-36

    enable password-min-length 6-36

    enable skip-page-display 6-36

    enable snmp config-radius 6-36

    enable snmp config-tacacs 6-37

    enable telnet authentication 6-37

    enable telnet password 6-37

    June 2005 3 - 7

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    enable-acl-counter

    encap-control

    end

    enforce-first-as

    erase flash primary

    erase flash secondary

    erase startup-config

    exclude-ports

    exit

    exit-address-family

    external-lsdb-limit

    fan init

    fan-read-speed

    fan read-temp

    fan set-speed

    fan-threshold

    fast port-span

    fast uplink-span

    fastboot

    fast-external-fallover

    fast-reload

    fdp enable

    fdp holdtime

    fdp run

    fdp timer

    filter

    filter-group

    flash

    flow-control

    force-sync-standby

    gig-default

    gig-default auto-gig rfn

    6-37

    21-1

    6-37, 10-2, 11-6,12-7, 14-2, 16-7, 18-3, 19-3, 20-4,

    18-10, 19-4, 20-4, 25-1

    17-8, 18-10

    5-28

    5-28

    5-28

    26-1, 26-3

    6-38, 10-2, 11-6, 12-8, 14-2, 16-7, 18-3, 19-3, 20-4,

    18-10, 19-4, 20-4, 25-1

    19-3, 20-4, 18-11, 19-5, 20-5

    15-10, 16-7

    6-38

    6-38

    6-39

    6-39

    6-40

    6-41

    6-41

    4-2, 5-29

    17-9, 18-11

    5-29

    8-5

    6-42

    6-42

    6-42

    13-2

    13-3

    6-42

    6-43, 8-6

    5-29, 7-2

    6-43, 8-6

    6-44, 8-6

    3 - 8 June 2005

  • Command List

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    global-protocol-vlan 6-44

    graft-retransmit-timer 23-2, 24-2

    group-router-interface 30-4

    gvrp-base-vlan-id 6-44

    gvrp-enable 6-44

    gvrp-max-leaveall-timer 6-45

    hardware-drop 24-2

    hello-interval 28-2, 29-2, 32-3

    hello-time 31-2

    hello-timer 24-3

    hold-down-interval 32-4

    hostname 6-45,18-4

    hw-drop-acl-denied-packet 6-45

    hw-module 6-46

    inactivity-timer 24-3

    interface 6-46

    interface group-ve 6-47

    interface link-hold-down 6-47

    ip access-group 8-7

    ip access-group flow-mode 8-7

    ip access-group frag deny 8-8

    Note: Standard only

    ip access-group frag deny 8-8

    Note: EP only

    ip access-group frag inspect 8-9

    ip access-group max-l4-cam 8-9

    ip access-group redirect-deny-to-interf 8-10

    ip access-group ve-traffic 8-10

    ip access-list 6-48

    ip access-list disable-log-to-cpu 6-49

    ip access-list frag-rate-on-interface 6-49

    ip access-list frag-rate-on-system 6-50

    ip access-list logging-age 6-50

    June 2005 3 - 9

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    ip access-policy 6-51

    ip access-policy-group 8-10

    ip address 8-11, 29-2, 32-5

    ip-address 28-2, 29-2, 32-5

    ip arp-age 6-52, 8-12

    ip as-path 6-52

    ip bootp-gateway 8-12

    ip broadcast-zero 6-53

    ip-cache age 6-53

    ip community-list 6-53

    ip default-network 6-54

    ip dhcp-valid-check 6-55

    ip directed-broadcast 6-55, 8-12

    ip dns domain-name 6-55

    ip dns server-address 6-55

    ip dont-advertise 8-13

    ip dont-use-acl 6-56

    ip dr-aggregate 6-57

    ip dvmrp advertise local 8-13

    ip dvmrp metric 8-13

    ip dvmrp ttl-threshold 8-14

    ip encapsulation 8-14

    ip flow-aggregation cache 6-57

    ip flow-cache timeout 6-58

    ip flow-export destination 6-59

    ip flow-export enable 6-59

    ip flow-export origin-as 6-60

    ip flow-export protocol-disable 6-60

    ip flow-export source 6-60

    ip flow-export version 6-61

    ip follow 8-14

    ip follow acl 8-15

    ip forward-protocol 6-61

    3 - 10 June 2005

  • Command List

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    ip helper-address 8-16

    ip helper-use-responder-ip 6-62

    ip high-perf 6-62

    ip hw-drop-on-def-route 6-63

    ip icmp 6-63, 8-16

    ip icmp echo broadcast-request 6-63

    ip icmp redirects 6-64, 8-16

    ip icmp unreachable 6-64

    ip igmp group-membership-time 6-65

    ip igmp max-response-time 6-65

    ip igmp query-interval 6-66

    ip igmp port-version 8-18

    ip igmp static-group 8-17

    ip igmp tracking 8-18

    ip igmp version 6-66, 8-18

    ip irdp 6-66, 8-18

    ip jumbo-mtu 8-19

    ip load-sharing 6-67

    ip load-sharing by-host 6-67

    ip load-sharing route-by-host 6-67

    ip metric 8-20

    ip mroute 6-68

    ip mtu 8-20

    ip multicast boundary 8-20

    ip multicast-perf 6-70

    ip multicast-routing 6-71

    ip nat inside 8-20

    ip nat inside destination list 6-71

    ip nat inside destination static 6-71

    ip nat inside source list 6-72

    ip nat inside source static 6-73

    ip nat outside 8-21

    ip nat pool 6-73

    June 2005 3 - 11

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    ip nat translation 6-74

    ip net-aggregate 6-74

    ip net-aggregate premium 6-75

    ip-net-aggregate supreme 6-76

    ip next-hop-movement log-disable 6-77

    ip ospf area 8-21

    ip ospf auth-change-wait-time 8-21

    ip ospf authentication-key 8-22

    ip ospf cost 8-23

    ip ospf database-filter 8-23

    ip ospf dead-interval 8-24

    ip ospf hello-interval 8-24

    ip ospf md5-authentication 8-24

    ip ospf network point-to-point 8-25

    ip ospf passive 8-26

    ip ospf priority 8-26

    ip ospf retransmit-interval 8-26

    ip ospf transmit-delay 8-26

    ip pim 8-27

    ip pim ttl 8-28

    ip pim-sparse 8-28

    ip policy frag-match-dst 8-28

    ip policy frag-match-src 8-29

    ip policy frag-match-src-dest 8-29

    ip policy prefer-direct-route 6-77

    ip policy route-map 6-77, 8-29

    ip prefix-list 6-77

    ip proxy-arp 6-78

    ip radius source-interface 6-78

    ip rarp 6-79

    ip rebind-acl 6-79

    ip redirect 8-29

    ip rip 8-30

    3 - 12 June 2005

  • Command List

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    ip rip filter-group 8-30

    ip rip learn-default 8-30

    ip rip metric-offset 8-31

    ip rip poison-reverse 8-31

    ip rip prefix-list 8-31

    ip rip route-map 8-31

    ip route 6-79

    ip route-cache flow 8-32

    ip router-id 6-80

    ip session tcp-msl 6-81

    ip show-acl-service-number 6-81

    ip show-portname 6-81

    ip show-service-number-in-log 6-82

    ip show-subnet-length 6-82

    ip source-route 6-82

    ip ssh authentication-retries 6-82

    ip ssh client 6-83

    ip ssh idle-time 6-83

    ip ssh key-size 6-83

    ip ssh password-authentication 6-83

    ip ssh permit-empty-passwd 6-84

    ip ssh port 6-84

    ip ssh pub-key-file 6-84

    ip ssh rsa-authentication 6-85

    ip ssh scp 6-85

    ip ssh source-interface 6-85

    ip ssh timeout 6-86

    ip ssl certificate-data-file 6-86

    ip ssl port 6-86

    ip ssl private-key-file 6-87

    ip strict-acl-out 6-87

    ip strict-acl-tcp 6-87

    ip strict-acl-udp 6-88

    June 2005 3 - 13

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    ip supernet connected 6-89

    ip tacacs source-interface 6-89

    ip tcp burst-normal 6-89, 8-32

    ip tcp keepalive 6-90

    ip tcp tcp-security 6-90

    ip telnet source-interface 6-91

    ip tftp source-interface 6-92

    ip ttl 6-92

    ip tunnel 8-33

    ip use-acl-on-arp 8-33

    ip verify unicast external-interface 8-34

    ip verify unicast reverse-path external 8-34

    ip verify unicast reverse-path external prefix-list 8-34

    ip vrrp 8-35

    ip vrrp auth-type 8-35

    ip vrrp-extended 8-35

    ip vrrp-extended auth-type 8-35

    ip vsrp auth-type 8-36

    ipg10 8-36

    ipg100 8-37

    ipg1000 8-37

    ip-proto 30-4

    ip-subnet 30-5

    ipv6 access-class 6-92

    ipv6 access-list 6-93

    ipv6 address 8-38

    ipv6 address [anycast] 8-38

    ipv6 dns domain-name 6-93

    ipv6 dns server-address 6-93

    ipv6 enable 8-39

    ipv6 hop-limit 6-93

    ipv6 icmp error-interval 6-94

    ipv6 load-sharing 6-94

    3 - 14 June 2005

  • Command List

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    ipv6 load-sharing by-host 6-95

    ipv6 mld port-version 8-39

    ipv6 mld max-response-time 6-95

    ipv6 mld query-interval 6-95

    ipv6 mld static-group 8-39

    ipv6 mtu 8-40

    ipv6 nd dad attempt 8-40

    ipv6 nd managed-config-flag 8-40

    ipv6 nd ns-interval 8-41

    ipv6 nd other-config-flag 8-41

    ipv6 nd prefix-advertisement 8-42

    ipv6 nd ra-interval 8-42

    ipv6 nd ra-lifetime 8-43

    ipv6 nd reachable-time 8-43

    ipv6 nd suppress-ra 8-43

    ipv6 neighbor 6-95

    ipv6 ospf area 8-44

    ipv6 ospf cost 8-44

    ipv6 ospf dead-interval 8-44

    ipv6 ospf hello-interval 8-45

    ipv6 ospf instance 8-45

    ipv6 ospf mtu-ignore 8-45

    ipv6 ospf network 8-45

    ipv6 ospf passive 8-46

    ipv6 ospf priority 8-46

    ipv6 ospf retransmit-interval 8-46

    ipv6 ospf transmit-delay 8-46

    ipv6 pim-sparse 8-47

    ipv6 prefix-list 6-96

    ipv6-proto 30-5

    ipv6 redirects 8-47

    ipv6 rip default-information 8-47

    ipv6 rip enable 8-48

    June 2005 3 - 15

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    ipv6 rip metric-offset 8-48

    ipv6 rip summary-address 8-48

    ipv6 route 6-97

    ipv6 router pim 25-1

    ipv6 router ospf 6-98, 8-49, 15-10

    ipv6 router rip 6-99, 8-49, 13-3

    ipv6 traffic-filter 8-50

    ipv6 unicast-routing 6-99

    ipv6 unnumbered 8-50

    ipx forward-filter 6-99

    ipx forward-filter-group 8-50

    ipx gns-reply-disable 8-51

    ipx gns-round-robin 6-100

    ipx netbios-allow 6-100, 8-51

    ipx network 8-51

    ipx output-gns-filter 8-51

    ipx-ping 4-2, 5-29

    ipx rip-filter 6-100

    ipx rip-filter-group 6-100, 8-52

    ipx rip-max-packetsize 8-52

    ipx rip-multiplier 8-52

    ipx sap-access-list 6-101

    ipx sap-filter 6-101

    ipx sap-filter-group 6-101, 8-53

    ipx sap-interval 8-53

    ipx sap-max-packetsize 8-53

    ipx sap-multiplier 8-53

    ipx update-time 8-54

    ipx-network 30-6

    ipx-proto 30-6

    join-timer 34-3

    kill 5-30

    l2-session-switch 8-57

    3 - 16 June 2005

  • Command List

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    learn-default 13-4

    link-aggregate active | passive | off 8-54

    link-aggregate configure 8-55

    link-fault-signal 8-56

    link-fault-signal legacy 8-56

    link-keepalive ethernet [vlan ] 6-102

    link-keepalive interval 6-103

    link-keepalive retries 6-103

    load-interval 8-57

    local-as 17-9, 18-11

    lock-address ethernet 6-103

    log 15-11

    logging 6-103

    log-status-change 16-8

    lp boot system flash 5-31, 6-106

    ip boot system interactive 5-31, 6-106

    lp boot system mp 5-32, 6-106

    lp boot system slot1 | slot 2 5-32, 6-107

    lp boot system tftp 5-32, 6-107

    lp-slot-priority 6-108

    lp sync all 5-33

    lsp-interval 17-6, 18-5

    mac deny-src-mac-filter-group 8-57

    mac filter 6-111

    mac filter log-enable 6-113

    mac filter-group 8-57

    mac filter-group log-enable 8-58

    mac-age-time 6-108

    mac-authentication apply-mac-auth-filter 8-58

    mac-authentication auth-fail-action block-traffic 8-58

    mac-authentication auth-fail-action restrict-vlan 8-59

    mac-authentication auth-fail-vlan-id 6-108

    mac-authentication auth-passwd-format 6-108

    June 2005 3 - 17

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    mac-authentication clear-mac-session 8-59

    mac-authentication disable-aging 6-109, 8-59

    mac-authentication dos-protection enable 8-59

    mac-authentication dos-protection mac-limit 8-60

    mac-authentication enable 6-109, 8-60

    mac-authentication enable-dynamic-vlan 8-60

    mac-authentication mac-filter 6-109

    mac-authentication max-age 6-110

    mac-authentication move-back-to-old-vlan 8-60

    mac-authentication no-override-restrict-vlan 6-110

    mac-authentication save-dynamicvlan-to-config 6-110

    mac-session-aging max-age 36-3

    mac-session-aging no-aging 36-3

    management-ip-disable 8-61

    management-vlan 30-6

    master 31-2

    master-vlan 33-1, 35-1

    match 27-1

    maximum 37-2

    maximum-number-of-lsa 15-11

    maximum-paths 17-9, 18-12, 20-5

    max-vlans 53-2

    maxreq 36-4

    med-missing-as-worst 17-10, 18-12

    member-group 33-2, 35-2

    member-vlan 33-2, 35-2

    message-interval 24-3

    metric 21-2

    metric-type 15-12, 16-8

    metro-ring 30-7

    mirror-port 6-114

    module 6-115

    monitor 8-62, 9-3

    3 - 18 June 2005

  • Command List

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    mrinfo 5-33

    msdp-peer 22-2

    mtraceroute 5-33

    multicast filter 6-115

    multicast limit 6-116, 8-63

    multicast-flooding 30-7

    multipath 17-10, 18-12, 20-5

    name 31-2

    nbr-timeout 23-2, 24-4

    ncopy tftp 5-36

    neighbor 13-4, 17-11 , 18-13, 19-5

    neighbor 20-6

    netbios-proto 30-8

    network 17-14, 18-17, 19-8, 20-8

    next-hop-enable-default 17-15, 18-17, 20-9

    next-hop-recursion 17-15, 18-18

    no 6-116, 10-3, 11-7, 12-8, 14-2, 16-8,18-6, 18-18, 19-5, 19-9, 20-4, 20-9, 25-1

    non-preempt-mode 28-2, 29-3, 32-5

    offset-list 13-4

    other-proto 30-8

    owner 28-2

    packet-logging 6-116

    packet-logging flash 6-116

    page-display 5-37

    password-change 6-117

    perf-mode 6-117

    permit 10-3, 11-7, 12-8

    permit icmp 12-9

    permit tcp 12-10

    permit udp 12-12

    permit redistribute 13-5, 15-13

    permit 12-13

    June 2005 3 - 19

  • Command Line Interface Reference for ProCurve 9300/9400 Series Routing Switches

    Table 3.1: Complete Layer 2/3 Command List (Continued)

    permit-l3jumbo 30-9

    phy-mode 8-63

    ping 4-3

    ping ipv6 4-4

    poison-local-routes 13-5, 14-2

    poison-reverse 13-6, 14-3

    port disable 38-1

    port keepalive 38-2

    port status_code 38-2

    port url 38-3

    port aps | bootp 6-118

    port security 8-63, 6-119

    port-name 8-63, 9-4

    port-priority 6-119

    power-off lp 5-38

    power-off snm 5-38

    power-on lp 5-38

    power-off snm 5-39

    prefix-list 13-6

    priority 8-64, 30-9

    privilege 6-119

    probe-interval 23-2

    prune-age 23-3

    prune-timer 24-4

    prune-wait 24-5

    pvlan mapping 30-9

    pvlan type 30-10

    pvlan-preference 6-120

    pvst-mode 8-64

    qd-flow sink 6-121

    qos mechanism 6-121

    qos name 6-122

    qos profile 6-122

    3 - 20 June 200